Announcement Announcement Module
Collapse
No announcement yet.
Installing vFabric Hyperic 4.5 (tc Server) on VMWare Windows Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Installing vFabric Hyperic 4.5 (tc Server) on VMWare Windows

    I am trying to install vFabric Hyperic 4.5 (part of latest tc Server Spring Edition). I could successfully install on Hyperic on regular Windows box but I am getting following error on VWWare Windows Server.

    It seems it is not able to start inbuilt postgres database. Could you please help in this regard. Your help is much appreciated.

    Code:
    Enter the fully qualified domain name of the SMTP server that HQ will use to send email messages [default 'TST01.main.com']:
    Enter an encryption key to use to encrypt the database password.:
    Loading install configuration...
    Install configuration loaded.
    Preparing to install...
    Validating server install configuration...
    Checking server webapp port...
    Checking server secure webapp port...
    Verifying admin user properties
    Validating server DB configuration...
    Installing the server...
    Unpacking server to: D:\Hyperic\...
    Creating server configuration files...
    Copying binaries and libraries to server installation...
    Copying server configuration file...
    Copying server db-upgrade files...
    Copying server libs...
    Setting up server database...
    Setting up JDBC driver...
    Copying database files...
    Configuring database...
    Loading taskdefs...
    Taskdefs loaded
    Starting repopulation of configuration table...
    Waiting for built-in database to start (on port 9432)...
    Starting built-in database...
    --------------------------------------------------------------------------------
    An ERROR occurred, the installation cannot continue.
    
    An error occurred trying to start the HQ built-in database.  More
     information may be available in the D:\Hyperic\/server-4.5.1-EE/logs/hqdb.log file.
    --------------------------------------------------------------------------------
    Waiting for server to stop...
    Stopping built-in database...
    Built-in database stopped.
    Installing the server JRE ...
    Unpacking JRE x86-win32-1.6.exe to: D:\Hyperic\/server-4.5.1-EE...
    Setting permissions on server binaries...
    Fixing line endings on text files...
    --------------------------------------------------------------------------------
    Installation Complete:
      Server successfully installed to: D:\Hyperic\/server-4.5.1-EE
    --------------------------------------------------------------------------------
    
     You should now install the HQ server as a Windows Service using this command:
    
      D:\Hyperic\server-4.5.1-EE\bin\hq-server.bat install
    
     You can then use the Service Control Manager (Control Panel->Services) to 
     start the HQ server.  Note that the first time the HQ server starts up it may
     take several minutes to initialize.  Subsequent startups will be much faster.
    
     Once the HQ server reports that it has successfully started, you can log in
     to your HQ server at: 
    
      http://TST01.main.com:7080/
      username: hqadmin
      password: hqadmin
    
     To change your password, log in to the HQ server, click the "Administration"
     link, choose "List Users", then click on the "hqadmin" user.
    
    
    Setup completed.
    A copy of the output shown above has been saved to:
      D:\hyperic-hqee-installer-4.5.1-win32\hyperic-hqee-installer-4.5.1\installer\logs\hq-install.log
    
    Press the Enter key to exit setup.
    I see the following error message in verbose hq install log file. I guess it is trying to start the db server and waiting for the response but failed to get any valid response.

    Code:
      [antcall] Exiting D:\hyperic-hqee-installer-4.5.1-win32\hyperic-hqee-installer-4.5.1\installer\data\setup-db-PostgreSQL.xml.
    Checking for listener at 127.0.0.1:9432
    Checking for listener at 127.0.0.1:9432
    Checking for listener at 127.0.0.1:9432
    Checking for listener at 127.0.0.1:9432
    Checking for listener at 127.0.0.1:9432
    Checking for listener at 127.0.0.1:9432
    Checking for listener at 127.0.0.1:9432
    Checking for listener at 127.0.0.1:9432
    Checking for listener at 127.0.0.1:9432
    Checking for listener at 127.0.0.1:9432
    Checking for listener at 127.0.0.1:9432
    Checking for listener at 127.0.0.1:9432
    Checking for listener at 127.0.0.1:9432
    Checking for listener at 127.0.0.1:9432
    Checking for listener at 127.0.0.1:9432
    Checking for listener at 127.0.0.1:9432
    Checking for listener at 127.0.0.1:9432
    Checking for listener at 127.0.0.1:9432
    Checking for listener at 127.0.0.1:9432
    Checking for listener at 127.0.0.1:9432
    waitfor: timeout
    Setting project property: hqdb.startup.error -> true
      [msgfail] failing due to ^^^ERROR:\
      [msgfail] An error occurred trying to start the HQ built-in database.  More
      [msgfail]  information may be available in the D:\Hyperic\/server-4.5.1-EE/logs/hqdb.log file.
    ^^^ERROR:\
    An error occurred trying to start the HQ built-in database.  More
     information may be available in the D:\Hyperic\/server-4.5.1-EE/logs/hqdb.log file.
    But at the same time I see following in hqdb log file
    Code:
    LOG:  database system was shut down at 2007-12-05 13:48:50
    LOG:  checkpoint record is at 0/487978
    LOG:  redo record is at 0/487978; undo record is at 0/0; shutdown TRUE
    LOG:  next transaction ID: 0/595; next OID: 16385
    LOG:  next MultiXactId: 1; next MultiXactOffset: 0
    LOG:  database system is ready
    Thanks,
    YA
Working...
X