Announcement Announcement Module
Collapse
No announcement yet.
Having problem running web app through STS. Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Having problem running web app through STS.

    Hi Folks,

    I'm pretty new to java and very new to Spring and STS, so bear with me a bit.

    I've been given an existing Maven project and can't seem to get it to run. The error I get is:

    java.lang.IllegalArgumentException: Document base /Users/supertom/springsource/tc-server-6.0.20.C/wtpwebapps/spring-mvc does not exist or is not a readable directory
    at org.apache.naming.resources.FileDirContext.setDocB ase(FileDirContext.java:142)
    at org.apache.catalina.core.StandardContext.resources Start(StandardContext.java:4048)

    Some more details

    # OS/software
    OS X 10.6.4

    # SpringSource Tool Suite
    Version: 2.5.0.RELEASE
    Build Id: 201010241000

    # Tomcat (the one that came with STS)
    tc-server-6.0.20.C

    # other configuration
    Project Facets: Dynamic Web Module and Java are checked (Details Pane)

    Target Runtime: SpringSource tc Server (Runtime) v6.0 (I've unchecked this as well in which case it just asks what runtime to use)

    # Notable:

    When I initially imported the project (Import -> existing maven projects) I got an NPE. No other info
    If I try to add/remove

    I verified no other tomcat is running, or any java processes for that matter before starting.

    I've actually done some tweaking and got the above error to go away, but now I just don't get anything in the wtpwebapps dir

    Nothing in the console about things not starting, etc. I just believe it isn't being copied to the directory.

    # Things I've tried:
    Updated mvn to 1.6 from 1.5 in my pom.xml
    Update Project Configuration as described here: http://forum.springsource.org/showpo...25&postcount=7
    build a war and copy it manually to the webapps folder - works
    tried developer addition tc server vs general tc server. Same issue
Working...
X