Announcement Announcement Module
Collapse
No announcement yet.
deploying Liferay application in TC server Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • deploying Liferay application in TC server

    I have copied the whole Liferay application directory into the CATALINA_BASE/webapps (= /home/tomcat/tcserver/springsource-tc-server-node/myserver/webapps) directory and then I started the TC RUNTIME instance. After the TC RUNTIME instance started, the Liferay application did not start. I checked in the logs and it showed that the liferay application was deployed.

    Did anyone experience similar issue? Any solution?

    Thanks

  • #2
    This is propably the same problem for LR and tc Server when I tried to run it. You have to modify wrapper.conf and change default value for stack size (eg. comment it out):
    #wrapper.java.additional.9=-Xss192k

    You should add some heap mem and modify permsize (values are examples) or liferay will crash with out of memory :-)
    wrapper.java.additional.8=-Xmx1024m
    wrapper.java.additional.9=-XX:MaxPermSize=512m

    I have posted complete solution few weeks ago:
    http://www.thrull.com/corner/webserv...ray-tc-server/

    Comment


    • #3
      Hi thrull,

      I have followed the steps suggested by yourself but could not bring it to work. I might have messed up somewhere. Below are the steps I took to deploy Liferay into TC:

      1. Unzipped liferay package and changed the liferay/tomcat-6.0.18/conf/server.xml with the port from 8080 to 9080 and all other ports in the 8000s to 9000s.

      2. Did the suggested changes in the myserver/conf/wrapper.conf

      3. Copied the whole unzipped liferay directory into myserver/webapps.

      4. Did ./tcruntime-ctl.sh start in myserver/bin.

      No errors were displayed in the logs but when I typed in http://localhost:8080, I get the springsource sample page. When I typed in http://localhost:9080, I get an error page. Do you know why?

      Thanks

      Comment


      • #4
        Sorry that was for windows, on *nix you have to edit <instance>/bin/setenv.sh

        Code:
        # JVM memory settings - general
        GENERAL_JVM_OPTS="-Xmx512m -Xss192k"
        and remove xss and propably add some heap memory.

        Comment

        Working...
        X