Announcement Announcement Module
Collapse
No announcement yet.
Insight web-app not working on clean install Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Insight web-app not working on clean install

    Hi!

    I'm running on an Windows XP machine with a fresh download of springsource-tc-server-developer.

    I extracted the files to a folder, opened a command window and ran:
    Code:
    tcruntime-ctl.bat spring-insight-instance run
    which shows the normal server startup information:
    Code:
    E:\springsource-tc-server-developer-2.0.0.SR01\springsource-tc-server-developer>tcruntime-ctl.bat spring-insight-instance run
    Running Windows architecture: win32
    INFO Service Information set.wrapper.ntservice.id=tcruntime-E-springsource-tc-server-developer-2.0.0.SR01-springsource-tc-server-developer-spring-insi
    ght-instance
    INFO Running instance at E:\springsource-tc-server-developer-2.0.0.SR01\springsource-tc-server-developer\spring-insight-instance
    wrapper  | --> Wrapper Started as Console
    wrapper  | Launching a JVM...
    jvm 1    | Wrapper (Version 3.2.0) http://wrapper.tanukisoftware.org
    jvm 1    |
    jvm 1    | May 18, 2010 12:08:13 PM org.apache.catalina.startup.Catalina load
    jvm 1    | INFO: Initialization processed in 1778 ms
    jvm 1    | May 18, 2010 12:08:14 PM org.apache.catalina.startup.Catalina start
    jvm 1    | INFO: Server startup in 1187 ms
    Looking at catalina.log, I get the following:

    Code:
    18-May-2010 12:08:12.347 INFO com.springsource.tcserver.security.PropertyDecoder.<init> tcServer property decoder has been initialized.
    18-May-2010 12:08:13.284 INFO com.springsource.tcserver.serviceability.rmi.JmxSocketListener.init Started up JMX registry on 127.0.0.1:6969
    18-May-2010 12:08:13.378 INFO org.apache.coyote.http11.Http11Protocol.init Initializing Coyote HTTP/1.1 on http-8080
    18-May-2010 12:08:13.456 INFO org.apache.catalina.core.StandardService.start Starting service Catalina
    18-May-2010 12:08:13.456 INFO org.apache.catalina.core.StandardEngine.start Starting Servlet Engine: SpringSource tc Server runtime/6.0.25.A
    18-May-2010 12:08:13.472 INFO org.apache.catalina.startup.HostConfig.deployDescriptor Deploying configuration descriptor manager.xml
    18-May-2010 12:08:14.300 INFO org.apache.catalina.startup.HostConfig.deployWAR Deploying web application archive insight.war
    18-May-2010 12:08:14.409 INFO org.apache.catalina.startup.HostConfig.deployDirectory Deploying web application directory ROOT
    18-May-2010 12:08:14.565 INFO org.apache.coyote.http11.Http11Protocol.start Starting Coyote HTTP/1.1 on http-8080
    It shows the apps being deployed

    The tc server work directory structure is created for each app, but the individual directories are all empty.

    I can get to the base page, showing the welcome page @ localhost:8080.

    Going to localhost:8080/insight or clicking the link gets a tc-404.

    Any ideas why this base setup is failing?
Working...
X