Announcement Announcement Module
Collapse
No announcement yet.
Cannot start tc Server Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot start tc Server

    Trying to just start the tc Server out of the box with a new STS install, I'm running into problems. I've included the error below.

    I first hit this trying to go through a tcServer demo, so I removed everything and reinstalled STS 2.3.2 from scratch. When it started, I just clicked on the SpringSource tc Server v6.0 in the Servers view and chose start. This is totally out-of-the-box.

    Any suggestions?

    ----------------------

    eclipse.buildId=2.3.2.201003230009-RELEASE
    java.version=1.6.0_17
    java.vendor=Sun Microsystems Inc.
    BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
    Framework arguments: -product com.springsource.sts.ide
    Command-line arguments: -os win32 -ws win32 -arch x86 -product com.springsource.sts.ide


    Error
    Thu Apr 01 09:46:40 EDT 2010
    Could not load the Tomcat server configuration at \Servers\SpringSource tc Server v6.0-config. The configuration may be corrupt or incomplete.

    org.eclipse.core.runtime.CoreException: Could not load the Tomcat server configuration at \Servers\SpringSource tc Server v6.0-config. The configuration may be corrupt or incomplete.
    at org.eclipse.jst.server.tomcat.core.internal.Tomcat 60Configuration.load(Tomcat60Configuration.java:31 3)
    at com.springsource.sts.internal.server.tc.core.TcSer ver60Configuration.load(TcServer60Configuration.ja va:236)
    at com.springsource.sts.internal.server.tc.core.TcSer ver.getTomcatConfiguration(TcServer.java:184)
    at com.springsource.sts.internal.server.tc.core.TcSer ver.getTomcatConfiguration(TcServer.java:1)
    at org.eclipse.jst.server.tomcat.core.internal.Tomcat ServerBehaviour.getTomcatConfiguration(TomcatServe rBehaviour.java:78)
    at com.springsource.sts.internal.server.tc.core.TcSer verBehaviour.getTomcatConfiguration(TcServerBehavi our.java:88)
    at com.springsource.sts.internal.server.tc.core.TcSer verBehaviour.getTomcatConfiguration(TcServerBehavi our.java:1)
    at org.eclipse.jst.server.tomcat.core.internal.Tomcat ServerBehaviour.setupLaunch(TomcatServerBehaviour. java:434)
    at com.springsource.sts.internal.server.tc.core.TcSer verBehaviour.setupLaunch(TcServerBehaviour.java:16 3)
    at org.eclipse.jst.server.tomcat.core.internal.Tomcat LaunchConfigurationDelegate.launch(TomcatLaunchCon figurationDelegate.java:96)
    at org.eclipse.debug.internal.core.LaunchConfiguratio n.launch(LaunchConfiguration.java:853)
    at org.eclipse.debug.internal.core.LaunchConfiguratio n.launch(LaunchConfiguration.java:703)
    at org.eclipse.debug.internal.core.LaunchConfiguratio n.launch(LaunchConfiguration.java:696)
    at org.eclipse.wst.server.core.internal.Server.startI mpl2(Server.java:3051)
    at org.eclipse.wst.server.core.internal.Server.startI mpl(Server.java:3001)
    at org.eclipse.wst.server.core.internal.Server$StartJ ob.run(Server.java:300)
    at org.eclipse.core.internal.jobs.Worker.run(Worker.j ava:55)

  • #2
    ShagVT,

    that is very strange as the server configuration is created on first launch of STS.

    Where did you install STS into?
    Where is your workspace?
    What is the contents of the Servers project in your workspace? Do you see any tc Server related files in there?

    Regards,

    Christian

    Comment


    • #3
      Thanks for responding!

      I installed to C:\java\springsource
      My workspace is in C:\projects

      My Servers project contains:
      .project
      SpringSource tc Server v6.0.server
      .settings\org.eclipse.wst.server.core.prefs
      SpringSource tc Server v6.0-config\ <empty dir>

      Comment


      • #4
        The content of my .server file is thus:
        ------------
        <?xml version="1.0" encoding="UTF-8" standalone="no"?>
        <server
        auto-publish-setting="2"
        auto-publish-time="1"
        com.springsource.tcserver.asf="true"
        configuration-id="/Servers/SpringSource tc Server v6.0-config"
        deployDir="wtpwebapps"
        hostname="localhost"
        id="SpringSource tc Server v6.0"
        id-set="true"
        name="SpringSource tc Server v6.0"
        runtime-id="SpringSource tc Server (Runtime) v6.0"
        server-type="com.springsource.tcserver.60"
        server-type-id="com.springsource.tcserver.60"
        start-timeout="120"
        stop-timeout="15"
        testEnvironment="false"
        timestamp="5"/>

        -----------------
        The content of the prefs file:

        #Fri Mar 26 12:55:00 EDT 2010
        org.eclipse.wst.server.core.isServerProject=true
        eclipse.preferences.version=1

        ----------------
        The content of the .project file:

        <?xml version="1.0" encoding="UTF-8"?>
        <projectDescription>
        <name>Servers</name>
        <comment></comment>
        <projects>
        </projects>
        <buildSpec>
        </buildSpec>
        <natures>
        </natures>
        </projectDescription>

        Comment

        Working...
        X