Announcement Announcement Module
Collapse
No announcement yet.
META-INF/hibernate.cfg.xml not found Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • META-INF/hibernate.cfg.xml not found

    Hi,

    I installed AMS server on my windows XP machine for some local tests. I used internal DB. When I try to start AMS server I got following error in the logs:

    2010-02-09 10:24:10,485 INFO [main] [org.jboss.deployment.EARDeployer] Init J2EE application: file:/C:/Programs/server-2.0.0.SR04/hq-engine/server/default/deploy/hq.ear/
    2010-02-09 10:24:14,141 INFO [main] [org.hibernate.cfg.Environment] Hibernate 3.2.6
    2010-02-09 10:24:14,141 INFO [main] [org.hibernate.cfg.Environment] hibernate.properties not found
    2010-02-09 10:24:14,156 INFO [main] [org.hibernate.cfg.Environment] Bytecode provider name : cglib
    2010-02-09 10:24:14,156 INFO [main] [org.hibernate.cfg.Environment] using JDK 1.4 java.sql.Timestamp handling
    2010-02-09 10:24:14,297 INFO [main] [org.hibernate.cfg.Configuration] configuring from resource: META-INF/hibernate.cfg.xml
    2010-02-09 10:24:14,297 INFO [main] [org.hibernate.cfg.Configuration] Configuration resource: META-INF/hibernate.cfg.xml
    2010-02-09 10:24:14,313 ERROR [main] [org.hyperic.hibernate.Util] Building SessionFactory failed.
    org.hibernate.HibernateException: META-INF/hibernate.cfg.xml not found
    at org.hibernate.util.ConfigHelper.getResourceAsStrea m(ConfigHelper.java:147)
    at org.hibernate.cfg.Configuration.getConfigurationIn putStream(Configuration.java:1411)
    at org.hibernate.cfg.Configuration.configure(Configur ation.java:1433)
    at org.hyperic.hibernate.Util.<clinit>(Util.java:101)
    at org.hyperic.hq.product.server.mbean.DatabaseInitia lizer$CommonRoutines.runRoutines(DatabaseInitializ er.java:132)
    at org.hyperic.hq.product.server.mbean.DatabaseInitia lizer.<init>(DatabaseInitializer.java:75)
    at org.hyperic.hq.product.server.mbean.DatabaseInitia lizer.init(DatabaseInitializer.java:55)
    at org.hyperic.hq.product.server.mbean.ProductPluginD eployer.<init>(ProductPluginDeployer.java:155)
    at sun.reflect.NativeConstructorAccessorImpl.newInsta nce0(Native Method)

    Indeed, the config file is not in the specified place.

    Thanks in advence..

  • #2
    Post configuration details

    Hi erhanbaz,
    Can you provide the executable name that you downloaded, and provide the information regarding your XP system - is it 32/64-bit, and what version of JVM are you using?

    -Sreedhar

    Comment


    • #3
      Hi,

      Setup fıle : "tcServer-6.0.20.C-GA-windows-x86.sfx.jar"
      JVM : java version "1.5.0_14"
      Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_14-b03)
      Java HotSpot(TM) Client VM (build 1.5.0_14-b03, mixed mode, sharing)
      OS : windows XP SP3 32 bit.

      Regards..

      Comment

      Working...
      X