Announcement Announcement Module
Collapse
No announcement yet.
i'm a beginner. Please, help me Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • i'm a beginner. Please, help me

    I installed softwares On Windows (Window 7):
    + JDK 1.6
    + SpringSource Tool Suite 2.3 (Included tc-server in path:
    C:\Program Files\SpringSource\tc-server-6.0.20.C\ )
    + PostgresSQL 8.4.2.1

    After these installation
    cmd >
    > C:\Program Files\SpringSource\tc-server-6.0.20.C\bin tcserver-ctl.bat --h
    and i received a message:
    "C:\Program Files\SpringSource\tcserver-ctl.bat"' is not recognized as an inter
    nal or external command,
    operable program or batch file.

  • #2
    Moved to tc Server forum for a better place to get you help.

    Christian

    Comment


    • #3
      Spaces are not allowed in the path. Try to install it in C:\dev or so, and it should work. I have no idea why in the world Program Files was chosen as default, when it doesn't work ...

      Comment


      • #4
        StudentABC,

        It looks form the paths that you are trying to start the ASF instance. I would recommend you follow the doc to create a new tcServer instance and start that instead.

        Use the "tcserver-instance.bat" script to create a new run-time tcServer instance. Then use the tcserver-ctl.bat script inside that instance's \bin directory to start that instance.

        Example:

        Code:
        tcserver-instance.bat -s myfirstinstance -j "c:\installs\java\jdk1.6.0_12"
        This will create a new instance called "myfirstinstance". You will see the new directory subtree created in the tcServer home. Then you can cd into "myfirstinstance\bin" and run the tcserver.ctl script there. That should start your instance.

        Hope this helps.

        Comment


        • #5
          Also - Windows 7 is not currently a supported operating system. I am also testing on Win7 (64-bit) and having some issues.

          Comment


          • #6
            Hey StudentABC - I have steered you wrong because I missed that you are using the dev edition. [which doesn't come with instance creation scripts]

            What worked for me is to ignore the tcserver-ctl.bat script. (I got the same error as you did and my install path does not have space and i am on WinXP). Just use the "startup.bat" script to start the instance instead:

            Code:
            C:\installs\sts\tc-server-6.0.20.C\bin>set JAVA_HOME="C:\installs\ers455-test\j6sdk"
            
            C:\installs\sts\tc-server-6.0.20.C\bin>startup
            
            Using CATALINA_BASE:   C:\installs\sts\tc-server-6.0.20.C
            Using CATALINA_HOME:   C:\installs\sts\tc-server-6.0.20.C
            Using CATALINA_TMPDIR: C:\installs\sts\tc-server-6.0.20.C\temp
            Using JRE_HOME:        "C:\installs\ers455-test\j6sdk"
            No guarantee since you are on win7, but that should hopefully get your tcServer instance up and running.

            Comment

            Working...
            X