Announcement Announcement Module
Collapse
No announcement yet.
Can't unpack tcServer-6.0.20.C-GA-devedition-PREVIEW.tar Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't unpack tcServer-6.0.20.C-GA-devedition-PREVIEW.tar

    Hi, I'm trying to install tc Server on my windows xp box using the platform neutral distribution and it won't work. I use 7zip to unpack the tar and it results in a folder named "C:\...\tcServer-6.0.20.C-GA-devedition-PREVIEW"
    containing the file "tcServer-6.0.20.C-GA-devedition-PREVIEW" and that's it. Isn't there supposed to be something more useful in that folder? Something I can actually interact with? :-( Also: I thought the developer version of the tc server was free? Why does it say 90-day evaluation on that form I had to fill in?

    Regards

    Kristofer

  • #2
    If installing on Windows, you should have downloaded or been given an sfx.jar file, which is a self-extracting jarfile. You would explode it via:

    java -jar blahblah.sfx.jar

    Comment


    • #3
      Hi Kristofer,
      Regarding the license, the license for the developer edition should be an unlimited End User License Agreement with no expiration as long as use is for development. I just went through the download myself and didn't see a license with the 90 day term. What path did you follow to get to this license? I'd like to make sure any flow through the website that leads you to a 90 day term license for downloading this edition is fixed.

      Regarding the installer issue, I've asked a few engineers to take a look. I know we've run through this successfully on Windows XP in the past.

      Thanks,
      Randy MacBlane

      Comment


      • #4
        If it helps, I ran WinZip on the .tgz file downloaded, it opened up the contained .tar file and when I extracted those files, I was able to run through the installation steps at http://static.springsource.com/proje...le.html#N101F4.

        Comment


        • #5
          Hi, thanks people for the quick reply. I managed to get it working. When I first tried extracting the files with 7zip I used the command Extract files... when I instead should have used Extract to "tcServer-6.0.20\".

          rmacblane: I've been trying to recreate what I did yesterday to make that "90-day evaluation"-message appear but I can't make it happen again. I'm sure I saw it in connection with trying to download the tc server but I have no idea how I managed to produce the page. I must somehow have navigated to the enterprise edition of the server(?)

          Comment


          • #6
            Glad you got working.

            No problem w.r.t. the license, I've passed along the issue to our web team to check out. I know there are a few different paths to get to the downloads, so I'm guessing we missed one path there with respect to having the correct license. I'll update here if/when we figure it out.

            Comment

            Working...
            X