Announcement Announcement Module
Collapse
No announcement yet.
Problem in starting the tcserver instance Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem in starting the tcserver instance

    I installed the tc server. But when I'm trying to run the tc server instance I'm getting the error and server is shutting down.

    *****************************************
    Running Windows architecture: win32
    wrapper | --> Wrapper Started as Console
    wrapper | Launching a JVM...
    jvm 1 | Wrapper (Version 3.2.0) http://wrapper.tanukisoftware.org
    jvm 1 |
    jvm 1 | WrapperSimpleApp: Unable to locate the class net.covalent.tomcat.wrap
    per.ThreadDumpWrapper: java.lang.UnsupportedClassVersionError: net/covalent/tomc
    at/wrapper/ThreadDumpWrapper (Unsupported major.minor version 49.0)
    jvm 1 |
    jvm 1 | WrapperSimpleApp Usage:
    jvm 1 | java org.tanukisoftware.wrapper.WrapperSimpleApp {app_class} [app_p
    arameters]
    jvm 1 |
    jvm 1 | Where:
    jvm 1 | app_class: The fully qualified class name of the application t
    o run.
    jvm 1 | app_parameters: The parameters that would normally be passed to the

    jvm 1 | application.
    wrapper | <-- Wrapper Stopped
    *****************************************
    Any help is highly appreciated.

  • #2
    You need a minimum of Java 1.5 to run tcServer
    Class Version Java
    49 0 1.5

    Comment


    • #3
      Hi,
      I changed my JAVA_HOME to point to jdk1.5, and also changed the the java_home entry in wrapper.conf to point to new jdk, but still I', encountering same issue.

      Do I need to reinstall everything using this new JDK version?

      **************************************
      Java -version from the jdk I'm pointing to
      C:\Program Files\Java\jdk1.5.0_17\bin>java -version
      java version "1.5.0_17"
      Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_17-b04)
      Java HotSpot(TM) Client VM (build 1.5.0_17-b04, mixed mode, sharing)
      **************************************
      set.JAVA_HOME=C:\Program Files\Java\jdk1.5.0_17\
      **************************************

      Comment


      • #4
        Hi,
        After little bit of digging, I went back and re-installed with everything using the new JDK version and everything went fine.
        Thanks again...

        Comment


        • #5
          Originally posted by akhil_katari View Post
          Hi,
          I changed my JAVA_HOME to point to jdk1.5, and also changed the the java_home entry in wrapper.conf to point to new jdk, but still I', encountering same issue.

          Do I need to reinstall everything using this new JDK version?

          **************************************
          Java -version from the jdk I'm pointing to
          C:\Program Files\Java\jdk1.5.0_17\bin>java -version
          java version "1.5.0_17"
          Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_17-b04)
          Java HotSpot(TM) Client VM (build 1.5.0_17-b04, mixed mode, sharing)
          **************************************
          set.JAVA_HOME=C:\Program Files\Java\jdk1.5.0_17\
          **************************************
          You just needed to reinstall the service. But it sounds like you got it working already.

          Comment

          Working...
          X