Announcement Announcement Module
Collapse
No announcement yet.
Manually starting tcServer not working Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Manually starting tcServer not working

    Just did a fresh clean install of tcServer, created a single instance and went to its bin and ran tcserver-ctl.bat start (just followed the steps in the Post Installation Instructions)

    This is windows XP and tcServer 6.0.20.A.

    I get the following error:
    C:\tcserver\tcServer-6.0\mytest\bin>tcserver-ctl.bat start
    Running Windows architecture: win32
    INFO Starting
    wrapper | The mytest-edd28 service is not installed - The specified service doe
    s not exist as an installed service. (0x424)

    According the post installation instructions shouldn't I be able to run this manually without installing the service? Installing the service does seem to fix the problem.

    Thanks

    ******
    PS the run command seems to work properly without the service installed and the start command works if the service is installed.
    Last edited by jmcginn; Aug 24th, 2009, 09:32 AM.

  • #2
    Hi,
    The start command for tcserver-ctl.bat requires prior installation as a windows service. Our documentation at http://static.springsource.com/proje...ing__reference should indicate that, I'll enter an issue to make that update.

    Other options at your disposal are:
    "run" - which runs tc server using the service wrapper and configuration without having to install as a windows service, this is a foreground invocation.
    "batch" - which runs tc server using catalina.bat directly, also a foreground invocation.

    I hope that helps.

    Thanks,
    Randy MacBlane

    Comment

    Working...
    X