Announcement Announcement Module
Collapse
No announcement yet.
AMS Management commons-logging error Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • AMS Management commons-logging error

    When restarting one of our applications via ams management console I get the following error:

    ###### tc Server ###### (10414) had an error: org.apache.commons.logging.LogConfigurationExcepti on: org.apache.commons.logging.LogConfigurationExcepti on: Invalid class loader hierarchy. You have more than one version of 'org.apache.commons.logging.Log' visible, which is not allowed. (Caused by org.apache.commons.logging.LogConfigurationExcepti on: Invalid class loader hierarchy. You have more than one version of 'org.apache.commons.logging.Log' visible, which is not allowed.) (Caused by org.apache.commons.logging.LogConfigurationExcepti on: org.apache.commons.logging.LogConfigurationExcepti on: Invalid class loader hierarchy. You have more than one version of 'org.apache.commons.logging.Log' visible, which is not allowed. (Caused by org.apache.commons.logging.LogConfigurationExcepti on: Invalid class loader hierarchy. You have more than one version of 'org.apache.commons.logging.Log' visible, which is not allowed.))

    The only way to recover is to restart the agent assoc. with tc Server. Has anyone run into this and have a suggestion?

  • #2
    Originally posted by cquirk View Post
    When restarting one of our applications via ams management console I get the following error:

    ###### tc Server ###### (10414) had an error: org.apache.commons.logging.LogConfigurationExcepti on: org.apache.commons.logging.LogConfigurationExcepti on: Invalid class loader hierarchy. You have more than one version of 'org.apache.commons.logging.Log' visible, which is not allowed. (Caused by org.apache.commons.logging.LogConfigurationExcepti on: Invalid class loader hierarchy. You have more than one version of 'org.apache.commons.logging.Log' visible, which is not allowed.) (Caused by org.apache.commons.logging.LogConfigurationExcepti on: org.apache.commons.logging.LogConfigurationExcepti on: Invalid class loader hierarchy. You have more than one version of 'org.apache.commons.logging.Log' visible, which is not allowed. (Caused by org.apache.commons.logging.LogConfigurationExcepti on: Invalid class loader hierarchy. You have more than one version of 'org.apache.commons.logging.Log' visible, which is not allowed.))

    The only way to recover is to restart the agent assoc. with tc Server. Has anyone run into this and have a suggestion?
    cquirk,

    Can you attach your agent.log file? That should give us a better look at the problem.

    -Jason

    Comment

    Working...
    X