Announcement Announcement Module
Collapse
No announcement yet.
Need install advise..... Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Need install advise.....

    I am trying to help a co-worker install some software and they need to run a file
    called run.sh
    this file came from this TAR tcServer-6.0.19.A-ams-linux-beta3.tgz


    this is the output i get.

    === Welcome to the SpringSource tc Server Installer ===

    First of all, we will be checking that you have the required
    dependencies to proceed...

    [Loaded groovy.lang.Script$print from file:/opt/tcserver-linux32-beta3/ijars/groovy-all-1.6.0.jar]
    Checking for compatible JVM... running Java5.
    Checking for java executable... [Loaded java.lang.ProcessBuilder from /usr/java/jdk1.5.0_18/jre/lib/rt.jar]
    [Loaded java.lang.ProcessImpl from /usr/java/jdk1.5.0_18/jre/lib/rt.jar]
    [Loaded java.lang.ProcessEnvironment from /usr/java/jdk1.5.0_18/jre/lib/rt.jar]
    [Loaded java.lang.ProcessEnvironment$ExternalData from /usr/java/jdk1.5.0_18/jre/lib/rt.jar]
    [Loaded java.lang.ProcessEnvironment$Variable from /usr/java/jdk1.5.0_18/jre/lib/rt.jar]
    [Loaded java.lang.ProcessEnvironment$Value from /usr/java/jdk1.5.0_18/jre/lib/rt.jar]
    [Loaded java.lang.ProcessEnvironment$StringEnvironment from /usr/java/jdk1.5.0_18/jre/lib/rt.jar]
    [Loaded java.util.Collections$UnmodifiableMap from /usr/java/jdk1.5.0_18/jre/lib/rt.jar]
    [Loaded java.lang.UNIXProcess from /usr/java/jdk1.5.0_18/jre/lib/rt.jar]
    [Loaded java.lang.UNIXProcess$Gate from /usr/java/jdk1.5.0_18/jre/lib/rt.jar]
    [Loaded java.lang.UNIXProcess$1 from /usr/java/jdk1.5.0_18/jre/lib/rt.jar]
    [Loaded java.lang.UNIXProcess$1$1 from /usr/java/jdk1.5.0_18/jre/lib/rt.jar]
    [Loaded java.lang.UNIXProcess$1$1$1 from /usr/java/jdk1.5.0_18/jre/lib/rt.jar]
    !!Error !!
    Your version of java cannot be found or is not compatible!

    [Loaded java_lang_System$exit from org.codehaus.groovy.runtime.callsite.CallSiteClass Loader]


    i changed the command in run.sh and added "-verbose" in hopes it would help.
    It did not.

    I have SLES 9.3 with these RPMS installed

    jre-1.5.0_17-fcs
    jdk-1.5.0_18-fcs

    I run the install as a user that has these env variables

    echo $PATH
    /home/admin/bin:/usr/local/bin:/usr/bin:/usr/X11R6/bin:/bin:/usr/games:/opt/gnome/bin:/usr/java/jdk1.5.0_18/bin

    echo $JAVA_HOME
    /usr/java/jdk1.5.0_18

    any help would be greatly appreciated ..... TIA

    -ALF ...
    Last edited by fazang; Apr 7th, 2009, 04:16 PM.

  • #2
    Chances are VERY good that this is due to the user running the Installer not having write permissions to the directory where the tcServer Installer is located.

    We agree that this is not obvious and the next release will have an explicit test for writability independent of looking for java.

    Comment


    • #3
      Bingo !!

      Thanx JIM !!!!
      Looks like you were onto something.....
      I ran " chown -R admin:users tcserver-linux32-beta3" and it seems to have done the trick.
      Well at least we get farther into the install, the menu showed up and i picked #4 to exit out. Hopefully this is what the SF admin needed from me and we are all set.

      TTYL

      -ALF out...

      Comment


      • #4
        I was having the same problem

        Just wanted to thank Jim for the post. I was having a similar problem which was resolved.

        Comment

        Working...
        X