Announcement Announcement Module
No announcement yet.
Port already in use: 6969 Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • Port already in use: 6969

    Hello everybody!

    I am trying to run two tc Server instances on a single machine.
    I use the script (provided by vFabric) to create the instances. During the creation of the second instance I pass the parameter -p bio.http.port=8081 to change the http listening port which works fine:
    Connector summary
    Port: 8081 Type: Blocking IO Secure: false

    But I cannot start the second server, catalina.out says:
    Error: Exception thrown by the agent : java.rmi.server.ExportException: Port already in use: 6969; nested exception is: Address already in use

    How can I change the jmx port during instance creation? I found out that the script in the instance directory uses the script in the main server directory where the jmx port is some kind of hardwired?!

    Any help is greatly appreciated.

  • #2
    I figured out that I can pass a different jmx port during the instance creation ( -p base.jmx.port=6970). The in the instance-dir/conf/ now reads: bio.http.port=8081, base.jmx.port=6970.
    When I try to start this instance the tc Server accepts the different http port but somehow disregards the jmx configuration and tries to use port 6969 instead.

    Forget about specifying the base.jmx.port during instance creation.
    Editing the instance-dir/bin/ is the (not very nice) solution for now.
    Last edited by disastermanagement; Dec 29th, 2011, 06:57 AM.


    • #3

      What version of tc Server are you using? I cannot reproduce this issue with 2.6.3. Passing either --interactive (where you can enter the jmx port manually) or specifying -p base.jmx.port=xxxx results in the property being stored correctly in and used on server startup.

      Any other details you can provide?


      • #4
        Thanks for your answer!
        I just tried to create another instance and passed the jmx port during the instance creation with -p base.jmx.port=xxxx. It worked like a charm.

        It was a tc Server 2.6.1 at the time I tried unsuccessfully. Last week I upgraded HypericHQ and tc Server without trying again. Now it's tc Server 2.6.3. The machine is running RHEL 5.7 x86_64 and JRE 1.6.0_30 (64 bit).
        Problem solved.