Announcement Announcement Module
Collapse
No announcement yet.
vFabric tc Server Developer Edition 2.5.1.RELEASE fail to start Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • vFabric tc Server Developer Edition 2.5.1.RELEASE fail to start

    Hi,

    I have a problem with starting tcServer.

    I am attaching you here steps to reproduce my problem:

    1. created instance of tomcat 6, using insight as template and port 9090
    Code:
    D:\tcServer>tcruntime-instance.bat create tomcat6 --version 6.0.32.C.RELEASE --property bio.http.port=9090 -t insight
    Creating instance 'tomcat6' ...
      Using separate layout
      Creating bin\setenv.bat
      Creating conf\wrapper.conf
      Applying template 'base'
        Copying template's contents
        Applying fragment 'context-fragment.xml' to 'conf/context.xml'
        Applying fragment 'server-fragment.xml' to 'conf/server.xml'
        Applying fragment 'web-fragment.xml' to 'conf/web.xml'
        Applying fragment 'tomcat-users-fragment.xml' to 'conf/tomcat-users.xml'
        Applying fragment 'catalina-fragment.properties' to 'conf/catalina.properties'
      Applying template 'base-tomcat-6'
        Copying template's contents
        Applying fragment 'server-fragment.xml' to 'conf/server.xml'
        Applying fragment 'web-fragment.xml' to 'conf/web.xml'
      Applying template 'insight'
        Copying template's contents
        Applying fragment 'context-fragment.xml' to 'conf/context.xml'
        Applying fragment 'server-fragment.xml' to 'conf/server.xml'
      Applying template 'bio'
        Copying template's contents
        Applying fragment 'server-fragment.xml' to 'conf/server.xml'
      Configuring instance 'tomcat6' to use Tomcat version 6.0.32.C.RELEASE
      Setting permissions
    Instance created
    Connector summary
      Port: 9090   Type: Blocking IO   Secure: false
    2. Installed this as service:
    Code:
    D:\tcServer>tcruntime-ctl.bat tomcat6 install
    INFO Running Windows architecture: winx86_64
    INFO Service Information set.wrapper.ntservice.id=tcruntime-D-tcServer-tomcat6
    INFO Instance name:       tomcat6
    INFO Script directory:    D:\tcServer\
    INFO tc Runtime location: D:\tcServer\
    INFO Instance base:       D:\tcServer
    INFO Binary dir:          D:\tcServer\\tomcat-6.0.32.C.RELEASE
    INFO Runtime version:     6.0.32.C.RELEASE
    INFO Script version:      2.5.1.RELEASE
    INFO Installing instance at D:\tcServer\tomcat6
    wrapper  | SpringSource tc Runtime instance - tcruntime-D-tcServer-tomcat6 installed.
    3. started service
    Code:
    D:\tcServer>tcruntime-ctl.bat tomcat6 start
    INFO Running Windows architecture: winx86_64
    INFO Service Information set.wrapper.ntservice.id=tcruntime-D-tcServer-tomcat6
    INFO Instance name:       tomcat6
    INFO Script directory:    D:\tcServer\
    INFO tc Runtime location: D:\tcServer\
    INFO Instance base:       D:\tcServer
    INFO Binary dir:          D:\tcServer\\tomcat-6.0.32.C.RELEASE
    INFO Runtime version:     6.0.32.C.RELEASE
    INFO Script version:      2.5.1.RELEASE
    INFO Starting instance at D:\tcServer\tomcat6
    wrapper  | Starting the SpringSource tc Runtime instance - tcruntime-D-tcServer-tomcat6 service...
    wrapper  | The SpringSource tc Runtime instance - tcruntime-D-tcServer-tomcat6 service was launched, but failed to start.
    and got error

    Here is the wrapper log:

    Code:
    STATUS | wrapper  | 2011/11/17 14:00:32 | SpringSource tc Runtime instance - tcruntime-D-tcServer-tomcat6 installed.
    STATUS | wrapper  | 2011/11/17 14:00:59 | Starting the SpringSource tc Runtime instance - tcruntime-D-tcServer-tomcat6 service...
    STATUS | wrapper  | 2011/11/17 14:00:59 | --> Wrapper Started as Service
    STATUS | wrapper  | 2011/11/17 14:00:59 | Launching a JVM...
    FATAL  | wrapper  | 2011/11/17 14:00:59 | Unable to execute Java command.  The system cannot find the file specified. (0x2)
    FATAL  | wrapper  | 2011/11/17 14:00:59 |     "java" "-Djava.endorsed.dirs=D:\tcServer\\tomcat-6.0.32.C.RELEASE\common\endorsed" "-Dcatalina.base=D:\tcServer\tomcat6" "-Dcatalina.home=D:\tcServer\\tomcat-6.0.32.C.RELEASE" "-Djava.io.tmpdir=D:\tcServer\tomcat6\temp" "-Djava.util.logging.manager=com.springsource.tcserver.serviceability.logging.TcServerLogManager" "-Djava.util.logging.config.file=D:\tcServer\tomcat6\conf\logging.properties" "-Dwrapper.dump.port=-1" "-Xmx512M" "-Xss192K" "-Dinsight.base=D:\tcServer\tomcat6/insight" "-Dinsight.logs=D:\tcServer\tomcat6/logs" "-Djava.awt.headless=true" "-Dgemfire.disableShutdownHook=true" "-Dgemfire.ignoreMisses=true" "-XX:MaxPermSize=256m" -Djava.library.path="D:\tcServer\tomcat6\bin\winx86_64" -classpath "D:\tcServer\tomcat6\bin\winx86_64\wrapper.jar;D:\tcServer\tomcat6\bin\winx86_64\threaddumpwrapper.jar;D:\tcServer\tomcat6/bin/insight-bootstrap-tcserver-1.5.0.RELEASE.jar;D:\tcServer\tomcat6/lib/aspectjweaver-1.6.11.jar;D:\tcServer\\tomcat-6.0.32.C.RELEASE\bin\bootstrap.jar;D:\tcServer\\tomcat-6.0.32.C.RELEASE\bin\tomcat-juli.jar" -Dwrapper.key="4lkAV7_YoBz1Jd18" -Dwrapper.port=32000 -Dwrapper.jvm.port.min=31000 -Dwrapper.jvm.port.max=31999 -Dwrapper.pid=4408 -Dwrapper.version="3.2.3" -Dwrapper.native_library="wrapper" -Dwrapper.service="TRUE" -Dwrapper.cpu.timeout="5" -Dwrapper.jvmid=1 org.tanukisoftware.wrapper.WrapperSimpleApp net.covalent.tomcat.wrapper.ThreadDumpWrapper start
    FATAL  | wrapper  | 2011/11/17 14:00:59 | Critical error: wait for JVM process failed
    ERROR  | wrapper  | 2011/11/17 14:01:01 | The SpringSource tc Runtime instance - tcruntime-D-tcServer-tomcat6 service was launched, but failed to start.
    Other valuable information follows:

    OS: Win 7 - 64-bit based

    Code:
    D:\tcServer>java -version
    java version "1.6.0_27"
    Java(TM) SE Runtime Environment (build 1.6.0_27-b07)
    Java HotSpot(TM) 64-Bit Server VM (build 20.2-b06, mixed mode)
    Any help would be appreciated.


    Thanx

  • #2
    It looks to me like java isn't on the PATH of the user that's running the service. How have you got your system's environment set up?

    Comment


    • #3
      Hi Andy

      I am attaching you system variables that has been set on my Win7 64bit machine.

      I am wondering, if you were right, that java is not on path, command java -version would not run either, right ?

      Thanks
      Attachment Attachment
      Attached Files

      Comment


      • #4
        There are two PATHs here: one for your user, and one for the user that's running the tc Server service. The fact that java -version works fine on the command line tells us that the PATH's configured correctly for your user. It doesn't tell us anything about the PATH for the user that'll run the service.

        Probably the easiest thing to do is to configure the PATH in the System variable section to add Java to it. That'll then apply to all users on your machine.

        Comment


        • #5
          Ah,

          thanks. I'll give it a try and get back with results.

          Anyway thanks for your help.

          Comment


          • #6
            Thank you Andy,

            it finally worked

            Comment


            • #7
              Great stuff. Thanks for letting us know.

              Comment


              • #8
                I have the exact issue:
                C:\Projects\tcbpm\visitor-instance\bin>tcruntime-ctl.bat start
                Derived instance name: visitor-instance
                Starting instance at C:\Projects\tcbpm\visitor-instance
                wrapper | Starting the VMware vFabric tc Runtime instance - tcruntime-C-Project
                s-tcbpm-visitor-instance service...
                wrapper | Waiting to start...
                wrapper | Waiting to start...
                wrapper | Waiting to start...
                wrapper | The VMware vFabric tc Runtime instance - tcruntime-C-Projects-tcbpm-v
                isitor-instance service was launched, but failed to start.

                I can run Java without any issue

                C:\Projects\tcbpm\visitor-instance\bin>java -version
                java version "1.7.0_06"
                Java(TM) SE Runtime Environment (build 1.7.0_06-b24)
                Java HotSpot(TM) Client VM (build 23.2-b09, mixed mode, sharing)

                Any clue what might be wrong?

                Thanks, Hua
                Originally posted by staleks View Post
                Thank you Andy,

                it finally worked

                Comment

                Working...
                X