Announcement Announcement Module
Collapse
No announcement yet.
java version vfrabic 2.5 tomcat-7.0.12.A.RELEASE Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • java version vfrabic 2.5 tomcat-7.0.12.A.RELEASE

    Hi

    What is the minimum java version for v7.0.12

    Works with JAVA_HOME=/usr/java/jdk1.6.0_23

    but I have an application that requires export JAVA_HOME=/usr/java/jre1.5.0_21

    In the catalina.out

    Exception in thread "main" java.lang.UnsupportedClassVersionError: Bad version n
    umber in .class file
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(Unknown Source)
    at java.security.SecureClassLoader.defineClass(Unknow n Source)
    at java.net.URLClassLoader.defineClass(Unknown Source)
    at java.net.URLClassLoader.access$100(Unknown Source)
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClassInternal(Unknown Source)
    Exception in thread "main" java.lang.UnsupportedClassVersionError: Bad version n
    umber in .class file

  • #2
    Tomcat 7 requires Java 6.

    If your app requires Java 5, then create a tcServer Runtime instance using Tomcat 6, and deploy your app there. The latest release of tcServer includes both Tomcat 6 and Tomcat 7.

    Doc Link

    Comment

    Working...
    X