Announcement Announcement Module
Collapse
No announcement yet.
How to shut off Web Flow logging messages? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • How to shut off Web Flow logging messages?

    In a Spring Webflow I have a modal popup, which works fine. However, there is a logging message that gets printed every time the modal popup is launched and I am trying to shut it off so it does not fill up the server's log file.

    I have not been able to figure out how to disable this logging message. Any ideas?

    I am using versions:
    Code:
     <webflow.version>2.1.1.RELEASE</webflow.version>
    <spring.version>3.0.3.RELEASE</spring.version>
    Logging message I would like to silence:

    Code:
    15:18:09.720 [18537968@qtp-13825521-2] WARN  o.s.w.mvc.view.FlowAjaxTilesView - An Ajax request was detected, but no fragments were specified to be re-rendered.  Falling back to full page render.  This can cause unpredictable results when processing the ajax response on the client.

  • #2
    I have not been able to figure out how to disable this logging message. Any ideas?
    OK, you could override your own log .properties file to off the WARN message just for o.s.w.mvc.view.FlowAjaxTilesView

    Comment


    • #3
      Perhaps I am confused, but the problem is that I cannot make this logging go away no matter what I try in my log4j.properties file. I suspect that it has to do with this being an AJAX javascript library and not going through log4j?

      Comment

      Working...
      X