Announcement Announcement Module
Collapse
No announcement yet.
Spring Webflow first setup build failed ! Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring Webflow first setup build failed !

    Dear All,

    I am new to Spring project setup. When I am setting up Spring webflow code base, I am getting the below error on building the downloaded source from Springsource. It seems to be related to the forking of VM.

    My System in Windows Vista, 2 GB RAM, AMD 32 bit env.

    Can anybody help here?
    Error log is attaced:

    Gokul

    Code:
      [s:javac]
    
    pps\helios_ws\gokz.apps.webflow\projects\spring-binding\t
    arget\test-classes
         [copy] Copying 1 file to D:\_gdata\_apps\helios_ws\gokz.apps.webflow\projects\spring-binding\target\test-classes
        [junit] Could not create the Java virtual machine.
        [junit] Error occurred during initialization of VM
        [junit] Could not reserve enough space for object heap
        [junit] Testsuite: org.springframework.binding.method.Batch-With-Multiple-Tests
        [junit] Tests run: 1, Failures: 0, Errors: 1, Time elapsed: 0 sec
        [junit]
        [junit] Testcase: org.springframework.binding.method.Batch-With-Multiple-Tests:null:        Caused an ERROR
        [junit] Forked Java VM exited abnormally. Please note the time in the report does not reflect the time until the VM exit.
        [junit] junit.framework.AssertionFailedError: Forked Java VM exited abnormally. Please note the time in the report does not refle
    ct the time until the VM exit.
        [junit]
        [junit]
       [subant] Leaving directory: D:\_gdata\_apps\helios_ws\gokz.apps.webflow\projects\spring-binding
    
    BUILD FAILED
    D:\_gdata\_apps\helios_ws\gokz.apps.webflow\projects\spring-build\multi-bundle\quality.xml:23: The following error occurred while exe
    cuting this line:
    D:\_gdata\_apps\helios_ws\gokz.apps.webflow\projects\spring-build\multi-bundle\common.xml:71: The following error occurred while exec
    uting this line:
    D:\_gdata\_apps\helios_ws\gokz.apps.webflow\projects\spring-build\common\quality.xml:36: The following error occurred while executing
     this line:
    D:\_gdata\_apps\helios_ws\gokz.apps.webflow\projects\spring-build\common\quality.xml:194: Tests failed (crashed)
    
    Total time: 5 minutes 11 seconds
    
    D:\_gdata\_apps\helios_ws\gokz.apps.webflow\projects\build-spring-webflow>ant

  • #2
    I haven't got a clue really on your specific problem, But I do wonder: What is the VM you're running/building on? Do other builds work fine on this VM?
    What is the IDE if any?

    Comment

    Working...
    X