Announcement Announcement Module
Collapse
No announcement yet.
Missing artifact 2.1.0.M2 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Missing artifact 2.1.0.M2

    I try to compile with STS spring-webflow-2.1.0.M2.
    But when I try update dependencies with maven I received:

    Missing artifact org.springframework.webflow:org.springframework.js :jar:2.1.0.M2:compile

    Which repository contains this artifact?

    Thanks.

  • #2
    This is the milestone repository:
    http://repository.springsource.com/m...dles/milestone

    You can also browse the EBR repositories here:
    https://s3browse.springsource.com/br.../maven/bundles

    For more background information see this:
    http://blog.springsource.com/2009/12...cts-with-maven

    Comment


    • #3
      I am getting a similar problem when trying to build the sample application (I was building the booking-portlet-mvc. I also get the following maven issues:

      Code:
      2 required artifacts are missing.
      
      for artifact:
        org.springframework.webflow.samples:booking-portlet-mvc:war:2.1.0.M2
      
      from the specified remote repositories:
        central (http://repo1.maven.org/maven2),
        com.springsource.repository.bundles.external (http://repository.springsource.c
      om/maven/bundles/external),
        com.springsource.repository.bundles.release (http://repository.springsource.co
      m/maven/bundles/release)
      How do we resolve this? Is there an issue with this release?

      Regards,

      Debashish

      Originally posted by srgsoroka View Post
      I try to compile with STS spring-webflow-2.1.0.M2.
      But when I try update dependencies with maven I received:

      Missing artifact org.springframework.webflow:org.springframework.js :jar:2.1.0.M2:compile

      Which repository contains this artifact?

      Thanks.

      Comment


      • #4
        Originally posted by Debashish View Post
        How do we resolve this? Is there an issue with this release?
        The pom.xml files for the samples don't seem to list the milestone repository. You need to add the following to the list of repositories in pom.xml:

        Code:
        <repository>
            <id>com.springsource.repository.bundles.snapshot</id>
            <name>SpringSource Enterprise Bundle Repository - Milestone Releases</name>
            <url>http://repository.springsource.com/maven/bundles/milestone</url>
        </repository>

        Comment


        • #5
          Originally posted by Rossen Stoyanchev View Post
          The pom.xml files for the samples don't seem to list the milestone repository. You need to add the following to the list of repositories in pom.xml:

          Code:
          <repository>
              <id>com.springsource.repository.bundles.snapshot</id>
              <name>SpringSource Enterprise Bundle Repository - Milestone Releases</name>
              <url>http://repository.springsource.com/maven/bundles/milestone</url>
          </repository>
          May be better use id like com.springsource.repository.bundles.milestone
          because already exists repository:
          <repository>
          <id>com.springsource.repository.bundles.snapshot </id>
          <name>SpringSource Enterprise Bundle Repository - Snapshot Releases</name>
          <url>http://repository.springsource.com/maven/bundles/snapshot</url>
          </repository>

          Now all ok. Thank you.

          Comment


          • #6
            Yes, indeed. So much for copy+paste.

            Comment


            • #7
              Thanks All

              Comment

              Working...
              X