Announcement Announcement Module
Collapse
No announcement yet.
Webflow 2.0.8 js compatibility with Dojox Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Webflow 2.0.8 js compatibility with Dojox

    I am trying to use dojox.grid.DataGrid on my jsp page and am getting an error reported in firebug when the page loads:

    dojo.destroy is not a function
    http://localhost:8080/mycart1/resour....js/eval/seq/5
    Line 16

    All the js and css files are loading correctly.

    I have tried using dojo-1.4.1 and dojo-1.3.2 but both give the same error.

    Is this a compatibilty issue between 'spring dojo' and dojox or is there some special recipe for making them work together?

    What version of dojox should I be using or is dojox strictly off the menu?

  • #2
    More info please

    hello could you post your flow definition, your views, your config files (between e.g. [ PHP ] [ /PHP ] tags)?

    Comment


    • #3
      Webflow 2.0.8 js compatibility with Dojox

      It's quite a big app, besides I'm only after some information regarding the use of dojox with spring as it is not included within the spring libraries. I simply need to know if there is a particular config and version mix that I need in order to make it work.

      Does anyone have any experience using dojox with spring?

      Comment


      • #4
        Webflow 2.0.8 js compatibility with Dojox

        It looks like it is a compatibility issue as dojox-1.2.3 works fine.

        Comment

        Working...
        X