Announcement Announcement Module
Collapse
No announcement yet.
Docs need update Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Docs need update

    Env: Tomcat 4.1, Spring 1.2.2, Spring Web Flow PR4

    Website states:
    - You need the core web flow jar, spring-webflow.jar.
    - You'll also need spring.jar and commons-logging.jar. These are both provided in the Spring 1.2 distribution.
    - To use the Struts 1.x integration, you'll need the neccessary Struts libraries.
    - To use the Spring MVC integration, you'll need spring-web.jar.

    In addition to the above, i had to download ognl to make the sellitem sample code work.

    Another note: PR4 samples assume support for schemas (web.xml). Had to change it back to the dtd version to make it work with tomcat 4.1

    Somebody plez update the docs, it will make life easier for an newbie like me.

    thanks,
    Ramiya

  • #2
    Those docs look correct to me and were recently updated.

    We favored J2EE 1.4 schema for the sample web.xml files simply because we're using JSP 2.0 (favoring its simplicity for demonstration purposes.)

    Yes, ognl is an indirect dependency used by the samples. However, if you use the provided build system (building with a 'ant dist' with ivy in the ant classpath) that will pull down the ognl.jar (and all other dependencies) automatically. See the readme.txt in the spring-webflow-samples directory.

    Comment


    • #3
      I improved the docs on the WIKI.

      Comment

      Working...
      X