Announcement Announcement Module
Collapse
No announcement yet.
PR4 and J2SE 1.3 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • PR4 and J2SE 1.3

    I was pleased to learn this morning that SWF PR4 was available and that the release ensured SWF could be run with J2SE 1.3. However, after obtaining the release, I encountered an 1.3 incompatibility in the binding library:

    java.lang.NoSuchMethodError: java.lang.IllegalStateException: method initCause(Ljava/lang/ThrowableLjava/lang/Throwable; not found
    at org.springframework.binding.expression.support.Exp ressionParserUtils.getDefaultExpressionParser(Expr essionParserUtils.java:49)

    I'm going to fix it, but since I'm not a developer, I can't commit it. Just wanted to bring it to your attention. Let me know if there is a better way to notify the team of these issues.

    Thanks and keep up the good work,
    Jason Southern

  • #2
    Unfortunately there are a few 1.3 issues with PR4, all centering around use of the initCause method of Exception (such a useful method but 1.4 only--don't know why I thought it was in 1.3)

    We've incorporated this one and a few others. Give whats in CVS a try on 1.3 and let us know.

    Keith

    Comment


    • #3
      Keith,

      Thanks for the quick response. I'll get the latest from CVS and let you know.

      Regards,
      Jason

      Comment

      Working...
      X