Announcement Announcement Module
Collapse
No announcement yet.
[Bug??] Struts 1.1 is not supported by SWF Preview 3 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Bug??] Struts 1.1 is not supported by SWF Preview 3

    [Description]
    Exception page appears when using Struts 1.1 and SWF Preview 3.

    [Environment]
    Struts 1.1 + SWF Preview 3 + Spring 1.2 + Hibernate 3.0.4.

    [Exception stack]
    java.lang.NoSuchMethodError: org.apache.struts.action.ActionForward.<init>(Lorg/apache/struts/action/ActionForwardV
    at org.springframework.web.flow.struts.FlowAction.toA ctionForward(FlowAction.java:224)
    at org.springframework.web.flow.struts.FlowAction.doE xecuteAction(FlowAction.java:143)

    [Related source code]
    FlowAction, line 222-227:
    Code:
    			ActionForward forward = mapping.findForward&#40;viewDescriptor.getViewName&#40;&#41;&#41;;
    			if &#40;forward != null&#41; &#123;
    				forward = new ActionForward&#40;forward&#41;;
    			&#125; else &#123;
    				forward = new ActionForward&#40;viewDescriptor.getViewName&#40;&#41;&#41;;
    			&#125;
    The constructor ActionForward(ActionForward copyMe) is since struts 1.2.1 and is unavailable in Struts 1.1 according to Struts API.

    Will Struts 1.1 be supported by SWF?

  • #2
    It could be that you have some old JARs on your classpath - these kind of problems often point to that.

    Rob

    Comment


    • #3
      This was a very last minute fix that we made to the FlowAction. I'll look into it.

      Thanks for spotting it!

      Erwin

      Comment

      Working...
      X