Announcement Announcement Module
Collapse
No announcement yet.
Webflow vs Spring version support table Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Webflow vs Spring version support table

    Hi,

    At present we are using Spring 2.5.6 and Spring web-flow 1.0 releases.

    We are upgrading Spring to the latest GA release along with Web-flow to latest GA release.

    But, as a short release plan we wanted to find, if we upgrade Spring to 3.1.2 or 3.2.3 release, will it affect the existing webflow1.0. Will there be any dependency if Spring is upgraded and not web-flow. The existing flow execution should happen without any code change?

    Also, is there is any table that tells me which/what version of web-flow is supported with Spring versions, then that also would help us in evaluating out release plans.

    Regards
    Sundhar

  • #2
    Spring Web Flow 1.0.x will not work with Spring 3.x. A patch is required to Web Flow for that combination to work. See here and here for more information.

    Comment


    • #3
      Thanks Laz for this patch info. I can hold upgrading Spring webflow to 2x, since it has lot of changes. I would better take as a separate activity.

      As you suggested, I created a webflow 1.0.6.1 patch build and things are working fine with Spring 3x.

      Thanks
      Sundhar

      Comment

      Working...
      X