Announcement Announcement Module
Collapse
No announcement yet.
evaluate expression never called Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • evaluate expression never called

    Hi,guys!
    I've got the questions m/b foolish

    I'm developing small webflow app which contains one top-level flow and some 7 subflows.
    Unexpectedly I encountered the following weird thing when deploying app to tomcat 6.0.26
    under NetBeans 7.2.1

    By some weird (to me) reason in the fragment below ONLY the first <evaluate expression ...
    block is executed. As I can see in debugger, first block is called,
    but the second one is even never called.
    If I swap them, then only previously second one is executed, but previously first block at it's turn - never.
    I've never seen in docs that two <evaluate ... /> blocks unacceptable in a single action-state
    or that it is impossible to assign a variable to flowScope twice
    (M/b loosely looked thru doc :-)

    and
    No exception thrown
    No error shown

    Am I missing something very simple?
    Please, help!
    TIA

    Code:
    <action-state id="itemChoicePrep">
    
        <evaluate expression="dbserviceimpl.getItemsByCategory(requestParameters.catId)"
            result="flowScope.itemsByCategory"
            result-type="java.util.List"/>
    
        <evaluate expression="dbserviceimpl.getCategory(requestParameters.catId)"
            result="flashScope.category"
            result-type="weborderflow.Category" /> 
            
        <transition to="itemChoice" />        
    </action-state>
Working...
X