Announcement Announcement Module
Collapse
No announcement yet.
Webflow + ApacheHTTP client Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Webflow + ApacheHTTP client

    Hi,
    my webflow application works just fine when used from a web browser. However, requirements are that I use an HTTP client to access the same application. It works fine to a certain point, but stops responding as soon as I have to start passing the webflow parameters eventId etc.

    Here are the basic assumptions I have made and implemented the client around:
    1. That I need to make every request to the webflow app a 'POST'
    2. That I have to pass the parameters in name-value-pair http object
    3. That the webflow parameters needed to function are eventId, and the value of 'flowExecutionUrl'
    4. Finally, the webflow app DOES have security around it. I'm logging in okay, and can see a secure page, but it is just at this point that the webflow app stops responding.

    Could anybody out there let me know if it is possible to go down this path based on assumptions above? I suppose more importantly, is there any reason why webflow would not work with an httpclient accessing it instead of a browser?

    I'm at my wits end so a response would be HIGHLY appreciated.

    Thanks in advance.

  • #2
    Hello

    However, requirements are that I use an HTTP client to access the same application. It works fine to a certain point, but stops responding as soon as I have to start passing the webflow parameters eventId etc.
    Could you expand more your bold requirement? Explicitly what do you want to do

    Finally, the webflow app DOES have security around it. I'm logging in okay, and can see a secure page, but it is just at this point that the webflow app stops responding.
    How you are doing this?, Are you working with Spring Security?

    BTW
    but stops responding as soon as I have to start passing the webflow parameters eventId etc.
    Are you receiving some error?, If yes, post all the error stack trace

    Comment


    • #3
      Problem resolved

      Hi,
      I got the problem resolved. It has nothing to do with webflow at all so it turned out, just the HTTPClient itself.

      Thanks for your response and time taken.

      Comment

      Working...
      X