Announcement Announcement Module
Collapse
No announcement yet.
Problem building Spring Social with Gradle Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem building Spring Social with Gradle

    Hi All,

    I am reasonably new to Gradle, and only started working with it since checking out the Spring Social source.

    I tried to use it to build Spring Social or generate the eclipse configuration files however every time I run it I get a number of the following errors:


    Could not compile script '/home/garyj/dev/workspace-social/spring-social/buildSrc/maven-deployment.gradle'.
    Cause: startup failed:
    /home/garyj/.gradle/caches/0.9-20101111130126+0300/scripts/maven_deployment_gradle_ab4942b2caab4c05bcd1754f9f 801298/no_buildscript_DefaultScript/maven_deployment_gradle_ab4942b2caab4c05bcd1754f9f 801298$_run_closure5_closure15_closure16_closure18 _closure20_closure21_closure24_closure26.class (File name too long)

    The path is 361 characters long which I believe is longer than the supported 255 characters on an ext4 filesystem!

    Any ideas on how I can resolve this would be much appreciated!

    Thank you

    Gary

  • #2
    Hi Gary,

    I've just posted the following to the Gradle-user mailing list:

    A user of one of our Gradle builds is running into 'File name too long' errors. See the full post:

    http://forum.springsource.org/showthread.php?t=100000

    He's on an ext4 filesystem which, as he presumes, does have a maximum filename length of 255 characters. However, I'm on OS X, and its HFS+ filesystem has the same filename length limit; I've never seen this issue.

    Any advice?

    If anyone else is on ext4 and cares to try reproducing the issue, do the following:

    git checkout --recursive git://git.springsource.org/spring-social/spring-social.git
    cd spring-social
    ./gradlew build

    if you run into an error about a missing 'remoteDocRoot' property, run the above as `./gradlew -PremoteDocRoot=/dev/null build`

    Thanks,

    - Chris
    Feel free to follow the thread yourself, but I'll also post back any resolution here.

    Comment


    • #3
      Environment Details

      Thank you for the reply Chris, reading through the thread Adam asked the environment details which are as follows:

      Ubuntu Linux 10.10 64bit

      Linux noodlesi7 2.6.35-24-generic #42-Ubuntu SMP Thu Dec 2 02:41:37 UTC 2010 x86_64 GNU/Linux

      java version "1.6.0_22"
      Java(TM) SE Runtime Environment (build 1.6.0_22-b04)
      Java HotSpot(TM) 64-Bit Server VM (build 17.1-b03, mixed mode)

      ext4 mount options:

      /home ext4 noatime,nodiratime,barrier=1,data=writeback,nobh,c ommit=100

      Locale: en_AU.utf8

      Thank you for your help

      Gary

      Comment


      • #4
        Hi Gary,

        Since this is looking much more like a core Gradle issue than it is something specific to Spring Social, I'd recommend posting directly in response to the mailing list thread. Especially since Adam is willing to try to reproduce this, it'll be good for you two to be in direct contact. You can just click the 'Subscribe' link at http://www.gradle.org/lists.html for the 'Users' mailing list. Once you've done than, then you can post.

        Cheers,

        - Chris

        Comment


        • #5
          Solved with Gradle 0.9.1

          This issue has been solved with Gradle 0.9.1.

          Thank you for all the help.

          Gary

          Comment


          • #6
            Glad to hear!

            Comment

            Working...
            X