Announcement Announcement Module
Collapse
No announcement yet.
Spring Social & Grails: no suitable HttpMessageConverter found Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring Social & Grails: no suitable HttpMessageConverter found

    Hi,

    I am trying to get spring social running in my Grails Application.

    I was able to get Twitter-OAuth-Conntection working and created a TwitterTemplate with the keys and secrets, but after the publish()-Call,
    an exception is thrown:

    Code:
    org.springframework.web.client.RestClientException: Could not extract response: no suitable HttpMessageConverter found for response type [java.util.Map] and content type [application/json;charset=utf-8]
    However, the tweet is successfully published. How do I set the Message-Converter?

    Thanks in advance,
    Adrian

  • #2
    Hi same problem did you had've a response?
    thx Rinaldo

    Comment


    • #3
      Not yet, but a workaround

      I just surrounded it with try/catch and went with it, since the Posts appeared at Twitter.

      Maybe we should post it on the Grails-User-List? Could be, that someone is already working on a grail splugin for that ;-)

      Comment


      • #4
        Can you please share how to get spring social working with grails

        Hi Guys

        I am trying to get spring social working with grails.
        Can you please share how to get this working given that there is no plugin.
        If you had written a blog on this or have a sample app you can share I would be thankful. You can reach me at trbala at yahoo.com

        Thanks
        Bala Thiruppanambakkam
        trbala at yahoo.com

        PS: I could get twitter posting working using twitter4j. Greenhouse has way too much than what I need.

        Comment


        • #5
          Hi, seems that the problem was library not included in my project.
          Include all the library and now jpsocial work fine.
          Asap I will release it as a plugin on the jAPS2.0 platform project.

          For more info contact me at rbonazzo at gmail dot com
          regards

          Comment


          • #6
            add these two jars it will work

            jackson-core-asl-1.7.2.jar

            and

            jackson-mapper-asl-1.7.2.jar

            Comment


            • #7
              Thx a lot 42rohan, al work fine. Asap I will wrote on my blog how I use spring socila to wrote the jAPS plugin jpsocial.
              Again thx to all for help
              Rinaldo

              Comment

              Working...
              X