Announcement Announcement Module
Collapse
No announcement yet.
dispatch to suburl Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • dispatch to suburl

    I don't get it ...
    What would i do, if i couldn't dispatch to the document root / ??
    I have the need to put all under something like localhost:8080/foo/ while localhost:8080/ is used by the vm by some other dispatcher who has the possibility to bypass me.
    but i fail to setup the dispatcher correctly, if i just change the mappings in web.xml it fails
    I have more leaks than just this, maybe i should change the security too, i tried that, but i don't get it correctly setup.
    I am working with the xml-samples, using even the non sec example to be as easy as possible.

    anyone in here who could tell me, what changes had to be done to publish under a given suburl correctly ??

    The Problem about this is, that ConnectController and ProviderSignInController are not mapped to the given suburl and i get a: HTTP ERROR 404

    Problem accessing /oauth/signin/facebook. Reason:

    I don't fullfull yet in also mapping that correctly.
    i tried to copy ProviderSignInController to a class with a deeper mapping (@RequestMapping("/oauth/signin")) and in the mapping i can see .RequestMappingHandlerMapping - Mapped "{[/oauth/signin/{providerId}], ..., but it still throws me that error
    <servlet-mapping>
    <servlet-name>appServlet</servlet-name>
    <url-pattern>/oauth/*</url-pattern>
    </servlet-mapping>

    Last edited by Held0fTheWelt; Apr 10th, 2014, 04:50 PM.

  • #2

    <bean class="org.springframework.social.connect.web.Connec tCon troller">
    <!-- relies on by-type autowiring for the constructor-args -->
    <property name="applicationUrl" value="${application.url}" />
    </bean>
    This doesn't work either ...
    Getting:
    org.springframework.beans.PropertyBatchUpdateExcep tion; nested PropertyAccessExceptions (1) are:|PropertyAccessException 1: org.springframework.beans.MethodInvocationExceptio n: Property 'applicationUrl' threw exception; nested exception is java.lang.NullPointerException

    I think that tells me, that i have given in the wrong application url, but that can't be ...
    i am just working at localhost and direct to /oauth/

    application.url=http://localhost:8080/oauth/

    Comment

    Working...
    X