Announcement Announcement Module
Collapse
No announcement yet.
Social, GWT and App Engine (pulling my hair out here!) Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Social, GWT and App Engine (pulling my hair out here!)

    Hi all, just joined.
    I started learning and using Social about a week ago, by implementing it into a GWT App Engine website with spring security.
    I did the normal stuff of downloading all the samples and working through them, but I have an issue I just cant get around.

    The symptoms are that I receive the following debug: WARN ProviderSignInController:177 - Exception while handling OAuth2 callback (The API package 'remote_socket' or call 'Resolve()' was not found.). Redirecting to /signin. (see it in the debug log file)

    The result is that I can sign into facebook but I am never forwarded to the post login page (or never forwarded if I am already logged into FB). And the application never executes the signin adapter. Also tried taking out the ProviderSignInController and using the ConnectController. Just keep getting "Error: Request method 'GET' not supported" even though I use a POST (tried GET too).

    Hopefully it is something really stupid and easy to solve.
    I have attached all the relevant files.
    Thanks,
    Paul.

    ps: all file extensions are TXT, as opposed to XML and Java, due to file manager constraints.
    Last edited by Paulie; Mar 11th, 2013, 03:52 AM.

  • #2
    First, thank you for the detailed explanation of your problem, including code and log files (I don't often get that kind of detail and it is very helpful).

    That said, I'm not sure I'm going to be able to help you, at least not right away. Due to GAE being a non-standard Java environment, there's been a bit of a challenge getting Spring Social to work in GAE. The whitelist (or more accurately, the things not on the whitelist) are one source of the problem. And considering the Spring Social leverages other libraries to do its work, that means that not only must Spring Social stick to the GAE whitelist, but those other libraries must also be confined to the whitelist.

    But there were a few bugs in GAE that also prevented me from getting Spring Social to work 100% in GAE. I came close on one occasion, but due to a bug in GAE I couldn't get ProviderSignInController to fully work.

    https://jira.springsource.org/browse/SOCIAL-73 is one issue that tracks some of this effort. But it has been well over a year since I've tried this again.

    But I wanted to see if I could at least figure out where this is failing in Spring Social to give some idea if there's a workaround. Unfortunately, line 177 in the latest ProviderSignInController code is a JavaDoc comment...clearly not the issue. So, I must ask: Which version of Spring Social are you using?

    Comment


    • #3
      Work around achieved, but without Social.

      Thanks Craig, that is very kind of you.
      It is really unfortunate that GAE has those issues with Spring Social. But then again, if you put your mind to it, you can surely achieve the desired result. If you can't then nobody can!

      Anyway, I have attached the project maven POM with the versions of all component (this will help you more than just the Spring versions).
      In the mean time I used the solution in http://techo-ecco.com/blog/creating-...e-web-toolkit/ (code in https://github.com/erezmazor/famousity.git)

      Craig, please let me know if you need anything more for your investigation into the underlying issues.
      All the best,
      Paul.

      Comment

      Working...
      X