Announcement Announcement Module
No announcement yet.
v1.0.2 tag build issues Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • v1.0.2 tag build issues

    I recently downloaded the spring source using git clone and it built fine using gradlew. I then checked out the 1.0.2RELEASE tag so as I'm only allowed using official released versions for the most part. The reason I need to compile spring social is I need a version that is officially released but can also incorporate a few patches for some bugs that have been fixed. I need the changes that were made for this: and this: I applied those 2 patches to 1.0.2release and then tried to build using gradlew and am getting this error:
    * Where:
    Script '/home/rvaldron/newworkspacesam/spring-social/buildSrc/docs.gradle' line: 18

    * What went wrong:
    A problem occurred evaluating script.
    Cause: Could not resolve all dependencies for configuration 'classpath':
    - unresolved dependency: org.apache.xerces#resolver;2.9.1: java.text.ParseException: Already seen doctype.
    - unresolved dependency: org.apache.xerces#xercesImpl;2.9.1: java.text.ParseException: Already seen doctype.

    I believe it's related to this:
    can anyone offer some advice? i'm not too familiar with gradle or maven to be honest.

    Is there something else I should be doing to build this tag?


  • #2
    well I managed to fix my own issue, I just changed line 40 in docbook.gradle to : mavenRepo name: 'Shibboleth Repo', urls: '' from what it was and it fixed it.