Announcement Announcement Module
Collapse
No announcement yet.
Running Spring Social samples in Google App Engine (GAE) Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Running Spring Social samples in Google App Engine (GAE)

    I just had my first try on getting the spring-social-showcase running on the Google App Engine platform (GAE). I didn't get it running. In the following lines, I'll present what I've been doing. I hope you can spot what I did wrong and tell me and the interested community what I must fix.

    I'm using Eclipse Indigo and Google Plugin for Eclipse (GPE).

    I cloned the spring-social-samples repository from github to my local drive. First I tried using the Maven Google App Engine Plugin (maven-gae-plugin), though this didn't bring me far (bad documentation).
    Then I tried running the sample from my Eclipse IDE using Eclipse Maven Integration (m2e). First, I imported the fresh repository clone into Eclipse ("File -> Import... -> Maven -> Existing Maven Project"). I followed the steps presented in this blogpost, section "Enabling Google Plugin for Eclipse to work with an existing Maven project". When I try to run the sample on the development server ("Run as... Web Application"), I get the following error

    Code:
    ERROR: org.springframework.web.context.ContextLoader - Context initialization failed
    org.springframework.beans.factory.BeanDefinitionStoreException: Failed to load bean class: org.springframework.social.showcase.config.MainConfig; nested exception is java.io.FileNotFoundException: class path resource [org/springframework/social/showcase/config/application.properties] cannot be opened because it does not exist
    That's where I don't know any further. I have no clue why "org/springframework/social/showcase/config/application.properties" is a missing class path resource.
    Do you know how to fix this problem?

    Thanks,
    Eduard

    P.S. In case you have a completely different workflow regarding GAE and Spring Social, please let us know.

  • #2
    I followed the same instructions from http://googlewebtoolkit.blogspot.com...r-eclipse.html
    and the standard spring-webmvc template project is running just fine, except that I needed to bring over a copy of the gae logging.properties files.

    Anyways, so once you do a maven build or install, and you look at the target build folder (e.g YOURPROJECT-1.0.0-BUILD-SNAPSHOT), is your properties file making into your classes folder?

    Comment

    Working...
    X