Announcement Announcement Module
Collapse
No announcement yet.
Maven config for 1.0.0.M3 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Maven config for 1.0.0.M3

    Guys,

    I'm starting a project to interact with Facebook or Twitter and I would like to use the latest milestone.
    After configure Maven for one of the components, I'm getting:

    Code:
    Missing artifact org.springframework:spring-aop:jar:3.1.0.M1:compile
    The POM configuration is this:

    Code:
    	<properties>
    		<project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
    		<org.springframework.social-version>1.0.0.M3</org.springframework.social-version>
    	</properties>
    
    	<dependencies>
    		<dependency>
    			<groupId>junit</groupId>
    			<artifactId>junit</artifactId>
    			<version>4.8.2</version>
    			<scope>test</scope>
    		</dependency>
    		<dependency>
    			<groupId>org.springframework.social</groupId>
    			<artifactId>spring-social-core</artifactId>
    			<version>${org.springframework.social-version}</version>
    		</dependency>
    		<dependency>
    			<groupId>org.springframework.social</groupId>
    			<artifactId>spring-social-facebook</artifactId>
    			<version>${org.springframework.social-version}</version>
    		</dependency>
    	</dependencies>
    
    	<repositories>
    		<!-- For developing against latest Spring milestones -->
    		<repository>
    			<id>org.springframework.maven.milestone</id>
    			<name>Spring Maven Milestone Repository</name>
    			<url>http://maven.springframework.org/milestone</url>
    			<snapshots>
    				<enabled>false</enabled>
    			</snapshots>
    		</repository>
    	</repositories>
    I will really appreciate your help on this,

    Thanks !

  • #2
    That's odd. I copied your pom.xml snippet and wrapped with with a minimal amount of pom.xml stuff (<project>, <groupId>, etc) and tried doing a build and it worked fine. I even removed my local Maven repo to make sure it wasn't finding spring-aop from a past build. It worked fine and it resolved spring-aop:3.1.0.M1 with no incident.

    One thing you might try is removing your local .m2/repository...or even digging into it and just removing the org/springframework/spring-aop directory and then trying again.

    Also, what you've pasted in is not the complete Maven pom.xml file. Could there be something else in the pom.xml that might prevent that from resolving correctly?

    Comment


    • #3
      Thanks for your reply, I tried at work and the spring-social-facebook module was retrieved fine.

      I think that my home environment has some special configuration that I might forget, I will try removing the repository.

      BTW, the pom.xml is fine, I just removed some stuff regarding <project>, <groupid>, etc.

      Comment

      Working...
      X