Announcement Announcement Module
No announcement yet.
STS 2.5.0.RELEASE + spring-flex.1.5.0.M1 - roo shell hangs Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Thx! I got it working now \/ - YAY!

    There was a bit of noob detection on my part. Initially I wasn't double clicking on the entities >.< and I wasn't keeping my mouse over the entity long enough to see the tooltip =P I was single clicking the Entity, it showed it as "selected" and I assumed it wasn't working.

    Beyond that, I figured out how to get STS to show the project as a "flex project" so users can actually see the flex configuration parameters etc.

    If you open up the .project file for a standard Flex application it has the following:

    <nature>com.adobe.flexbuilder.project.flexnature </nature>
    <nature>com.adobe.flexbuilder.project.actionscript nature</nature>

    The <buildCommand> and both <nature/> are not present inside the .project file that is managed by the flex-roo plugin. If you hand copy them into the default created .project, Flash Builder 4 was able to pick up on it right away.

    Is this something the roo-flex plugin could manage?

    I also noticed that the default startupURL that is generated goes to the root, instead of the <projectName>_scaffold.html


    The .actionScriptProperties file contains the location that this opened by default when you choose to run application in the browser. If this file is manged by roo it could be updated to


    Again thanks for all the hard work you and your team are doing to integrate spring with the various APIs (Flex, Comet etc.) these are platforms people are already using and making it easier to configure and manage leaves more time for coding =P



    • #17
      STS 2.52 + Roo 1.1.1 + spring-flex-1.5.0.M1 hangs indefinitely

      In order to make with work Maven and Spring build, I set up STS 2.5.2 + Roo 1.1.1 + spring-flex-1.5.0.M1 and Flex4 plug-in as shown in the youtube video, but Roo shell hangs indefinitely even when creating the persistency layer. Can any one advise how to resolve this issue. Thanks