Announcement Announcement Module
Collapse
No announcement yet.
Any luck with STS 2.3 + Flash Builder 4 plugin? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by jeremyg484 View Post
    Why not just use the STS installer executable? Makes this process much easier.
    Because the downloadable versions of STS are for newer releases of Eclipse and Flash Builder 4 is too far behind the curve.
    According to FB4 download site, I need Eclipse 3.4.2 or 3.5 as a base. (Mac Carbon Plugin)
    https://www.adobe.com/cfusion/tdrc/i...=flash_builder
    Ganymede SR2 = 3.4.2
    Galileo = 3.5

    STS site doesn't provide link to go back into archives for appropriate release.

    PS: This was the content of that unreachable Bookmark.XML file posted in the other forum

    <bookmarks>
    <site url="http://dist.springsource.com/release/TOOLS/update/e3.5" selected="true" name="SpringSource Update Site for Eclipse 3.5"/>
    <site url="http://dist.springsource.com/release/TOOLS/composite/e3.5" selected="true" name="SpringSource Update Site for Eclipse 3.5 (Dependencies)"/>
    <site url="http://download.eclipse.org/releases/galileo" selected="true" name="Galileo"/>
    </bookmarks>

    I think the second site, the (Dependencies) 'composite' link is bogus... Was wondering what the proper links were. As I did spot springsource.com/update/e3.5 in the screenshot for the PDF earlier and wonder if this was a red herring...

    I did try the milestone Groovy Eclipse plugin link instead and got past that but then had some Mylyn dependency issue. :-(
    Last edited by JGF; Oct 8th, 2010, 02:17 PM.

    Comment


    • #17
      Originally posted by JGF View Post
      Because the downloadable versions of STS are for newer releases of Eclipse and Flash Builder 4 is too far behind the curve.
      According to FB4 download site, I need Eclipse 3.4.2 or 3.5 as a base. (Mac Carbon Plugin)
      https://www.adobe.com/cfusion/tdrc/i...=flash_builder
      Ganymede SR2 = 3.4.2
      Galileo = 3.5
      I believe those are just meant to be minimum requirements. I've got the Flash Builder plugin installed in the Eclipse 3.6 Carbon version of STS 2.5.0.M3 with no issues.

      Comment


      • #18
        Ah that's a load off then... I'm was at my wits end.. Will give that a Whirl. Wish the Adobe guys had been clearer on this point :-)

        Comment


        • #19
          any luck with flexmojos?

          I'm using STS 2.5.0 + m2eclipse + FB4. I'm trying to use flexmojos to compile/package all this with maven.

          After using the flexmojos-archetypes-modular-webapp archetype I tweak the flex compiler/framework, remove the swc component and dependencies created by the archetype and run 'mvn flexmojos:flashbuilder'. I can then import my parent and two modules (war and swf) into STS/FB without issue.

          But three things happen when I try and develop:

          1) Content assist does not work for mxml. I definitely have the file opened in the MXML editor.
          2) If I switch to design view for the same file it says "an unknown item is declared as the root of your MXML document."
          3) if I try and create a new MXML Component, no matter what base component I choose, it says "The base component class does not exist."

          I suspect all these things are related, but for the life of me I can't figure out what. In beta versions of FB4 people complained of similar issues with respect to no content assist.

          I have even created a new Flex project via File -> New -> Flex Project, and copied the project files (.project, .actionScript...) to my maven module, closed and reopened the project and nothing.

          Has anyone gotten this to work?

          Comment


          • #20
            No, I've never been able to get the flexmojos:flashbuilder command to work cleanly either. (That's why we essentially just create the metadata ourselves in the Roo addon as part of the 'flex setup' command.)

            What I've found to work well is to just do File -> New -> Flex Project and point to the location of your existing project, then tweak the settings as necessary after it's created to get the paths set up to match the conventions of the Flex Mojos.

            Comment


            • #21
              I gave up on using FB4 with STS and went with the stand alone. Will use Roo with STS as seperate install and IntelliJ for Grails. Way too may glitches.

              Comment


              • #22
                Jeremy, I am in the midst of upgrading my environment and wanted to run some things by you. FB requires Carbon based on Adobe documentation, but I am assuming from the post below that you believe that STS 2.5 running e3.6 will work with FB4 plug-in. Thank you all the information so far.

                Originally posted by jeremyg484 View Post
                I believe those are just meant to be minimum requirements. I've got the Flash Builder plugin installed in the Eclipse 3.6 Carbon version of STS 2.5.0.M3 with no issues.

                Comment

                Working...
                X