Announcement Announcement Module
Collapse
No announcement yet.
Any luck with STS 2.3 + Flash Builder 4 plugin? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Any luck with STS 2.3 + Flash Builder 4 plugin?

    Has anyone had any luck installing the Flash Builder 4 plugin into STS 2.3 (or, I guess eclipse 3.5.1) ? Specifically on OS X, I guess.

    The installation of FB4 goes alright, but it doesn't seem to install anything into STS even though I give it STS as the eclipse folder to use.

    Just wondering if it works for anyone else and if I should try again.

  • #2
    Yeah, I've gotten it to work, but it does require some minor manual intervention.

    The plugin(s) are designed to work by just putting a link in the dropins folder of your Eclipse installation. After the installer completes, you should have something like a "/Applications/Adobe Flash Builder Plug-in Beta 2" folder. From there, look in "/eclipse-host-distro/dropins". The link you need is in there. Copy that link into the dropins folder of your STS install. It should get picked up the next time you start STS.

    Comment


    • #3
      Thanks! I just tried it and it works as expected.

      Comment


      • #4
        no luck for me...

        I've tried a couple of times to integrate FB4 plugin with STS-2.3
        1: told the FB4 installer about STS; [uninstall/reinastall FB4-plugin]; 2: manually copying the link to the dropin directory

        Either way, on starting, STS explodes with a plethora of errors (see attached screen shot)
        culminating with a popup informing me: An internal error occurred during: "Creating Adobe Flash Player trust file...".

        Looks like missing or conflicting files, but where would Eclispe/STS be looking?

        If someone knows more about Eclipse (or FB4) and can suggest a way forward, that will be appreciated.

        Both "Flash Builder 4" (standalone) and the Adobe-supplied Ganymede+FB4plugin work.

        This on Vista-64, if that matters.
        Last edited by Jack Punt; Feb 17th, 2010, 01:30 PM.

        Comment


        • #5
          I don't know how to help you, but I can say that I've been using STS 2.3 (carbon version) + FB4 plugin every day for a week on Mac OS X 10.6 without any error. So it might very well be Windows or Windows 64 specific.

          Here are the specific steps I followed.

          1. Download and install SpringSource Tool Suite 2.3 (Carbon version) into /Applications/springsource.
          2. Download and install the Flash Builder 4 Beta 2 plugin for Eclipse. When prompted for your Eclipse directory, choose the sts subfolder of the same folder you installed STS into: /Applications/springsource/sts-2.3.0.RELEASE
          3. Copy the file /Applications/Adobe Flash Builder Plug-in Beta 2/eclipse-host-distro/dropins/com.adobe.flexbuilder.feature.core.nl1.link to /Applications/springsource/sts-2.3.0.RELEASE/dropins
          4. (Optional) If you want to do Flex 3.5 development, Download the Flex 3.5a SDK and install it into /Applications/Adobe Flash Builder Plug-in Beta 2/sdks/3.5a
          5. Launch STS
          6. (Optional, if you want Flex 3 support) Choose a new workspace for content development, so as to not pollute your other projects with Flash Builder 4 metadata that would make them unopenable in Flex Builder 3.
          7. When prompted for a Flash Builder license, you can either use it for a trial or request a Flash 4 license using your current Flex Builder 3 license code.
          8. Configure your Flex SDKs in the STS preferences. Optionally, Add your Flex 3.5a sdk to the list and make it the default for projects.
          9. Install whatever other plugins you may need (such as subclipse) and restart STS as part of the installation.

          Comment


          • #6
            no BridgeTalk in java.library.path

            Ah, the light is beginning to come through.
            The root cause of failure seems to be: "Caused by: java.lang.UnsatisfiedLinkError: no BridgeTalk in java.library.path"

            Presumably because BridgeTalk.class looks for native dll, which sits in ...\eclipse\plugins\com.adobe.flexide.nativelibs_4 .0.0.253292\os\win32\x86\
            This plugin & dll works in the 'standalone' FB4 (where everything is in the plugin directory)
            and the adobe-supplied eclipse-host-distro (3.4,Ganymede), where it uses a dropin link;

            What is different about STS (3.5) ?
            Can someone say how to set java.library.path so STS will find this?
            Or other solution?

            Comment


            • #7
              Flash Builder 4 fails on 64-bit jre

              Oh, I get it now!

              Adobe installs/uses its own (32bit) jre.
              So the 32bit.dll works for them.
              But using a 64bit jre, all is lost...
              https://bugs.adobe.com/jira/browse/FB-26041
              Last edited by Jack Punt; Feb 18th, 2010, 03:25 PM.

              Comment


              • #8
                same in mac 10.6.2

                I too see the same error . STS 2.3.3M1 + FB4 plugin. The standalone FB4 works fine.

                Caused by: java.lang.UnsatisfiedLinkError: no BridgeTalk in java.library.path

                Additionally i see
                Caused by: java.lang.NoClassDefFoundError: com/adobe/flexbuilder/util/PluginProperties

                Caused by: java.lang.NoClassDefFoundError: com/adobe/flexide/editorcore/document/IFlexDocument

                etc in the STS eclipse log.

                Is there a way out for this ??!!

                Comment


                • #9
                  I'm using it on Mac with no issues. Are you using the 64bit version? As pointed out by Jack, I don't believe that combo works.

                  Comment


                  • #10
                    switching to carbon - mac os

                    yes. i was using a cocoa-64bit. Now its fine.. Thanks for the info

                    Comment


                    • #11
                      Cannot compile and run Roo generated Flex projects in STS 2.3.3.M2

                      I'm running Flash Builder 4 in STS and the flex projects created by Roo are not recognized by the plug in. There is no code hinting or recognition of actionscript in .as files and the script blocks in MXML files appear in black text.

                      I can create and run other standard Flex projects in STS, just the projects created by Roo dont seem to be recognized. Has anyone come across this particular oddity?

                      Comment


                      • #12
                        After running roo scripts don't import as "Existing Maven project". Run "mvn eclipse:eclipse" this will generate eclipse project files. After this do import as "General -> Existing project in workspace".

                        This way we are able to see syntax highlighting and autocomplete for mxml , a script

                        Comment


                        • #13
                          Ok I'll give that a shot.

                          In the Introducing the Flex add on for Spring Roo screen cast that Jeremy posted, I see that when he runs flex setup there are quite a few more project files created that are not created when I run that command. It looks like all the template files after the rootunes_scaffold.html file. Actually everything flex related(swfs) that would go into the webapp folder.

                          I do have some build errors calling out aspectj 1.6.10.M1 as missing but this is in my local repository and the project otherwise fuctions as expected.

                          It seems to me that there is something else specific to the flex setup command that is causing this particular issue.

                          Comment


                          • #14
                            Getting STS to work with FB4 Install hiccups.

                            I've tried doing the Eclipse Galileo 3.5 J2EE (Mac Carbon) install and follow the install from the update manager approach in order to try and get everything to work together.

                            The first snag I hit was the bookmarks file didn't do a download, but I found the code to manually create the XML file here
                            http://forum.springsource.org/archiv...p/t-91708.html

                            Now when I get to the stage where I get to the point 4 d) I get problems with a missing Groovy dependency.
                            (After it's calculated the requirements & dependencies - you get to the Install Details
                            I get:

                            Cannot complete the install because one or more required items could not be found.
                            Software being installed: SpringSource Tool Suite Grails Support 2.3.2.201003230009-RELEASE (com.springsource.sts.grails.feature.group 2.3.2.201003230009-RELEASE)
                            Missing requirement: SpringSource Tool Suite Grails Support 2.3.2.201003230009-RELEASE (com.springsource.sts.grails.feature.group 2.3.2.201003230009-RELEASE) requires 'org.codehaus.groovy.eclipse.feature.feature.group 2.0.0' but it could not be found

                            PS: I do Grails development too. So I need that...

                            I'm going to try downloading the Groovy Eclipse plug-in first before doing the STS stuff... Wondering if this will fix the glitch. The PDF needed to include that step maybe.
                            I Googled in on this:
                            http://groovy.codehaus.org/Eclipse+Plugin
                            So added this and will give that a whirl first...
                            http://dist.springsource.org/release/GRECLIPSE/e3.5/

                            My goodness this is fragile stuff..
                            The install of the Groovy Eclipse Plug-in fails...

                            An error occurred while collecting items to be installed

                            Artifact org.eclipse.update.feature,org.eclipse.jdt,3.5.1.r 351_v20090810-0600-7r88FEoFI0WTo6Az-1qFRHm37ChJ is a folder but the repository is an archive or remote location.
                            Artifact osgi.bundle,org.junit4,4.5.0.v20090824 is a folder but the repository is an archive or remote location.
                            session context wasprofile=epp.package.jee, phase=org.eclipse.equinox.internal.provisional.p2. engine.phases.Collect, operand=, action=).

                            I'm also a bit perplexed at the indication of a 3.5.1 artifact in there too, as I installed the base 3.5 release of Eclipse
                            Last edited by JGF; Oct 8th, 2010, 02:13 PM.

                            Comment


                            • #15
                              Why not just use the STS installer executable? Makes this process much easier. Once you've got a working installation, adding the Flash Builder plugin is done by just copying the proper link into the dropins folder.

                              I've never tried to install STS from the update manager, so wouldn't know where to begin to help you on that front. The more appropriate place for general STS questions like that is the Spring Development Tools forum:
                              http://forum.springsource.org/forumdisplay.php?f=32

                              Comment

                              Working...
                              X