Announcement Announcement Module
Collapse
No announcement yet.
spring-flex + spring-osgi + spring 3.0.0.M4 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • spring-flex + spring-osgi + spring 3.0.0.M4

    Hi,

    I am currently runing a webapp using spring osgi 1.2 together with spring security 3.0.0.M1 and spring 3.0.0.M4.

    I would like to intergrate spring-flex into this webapp. With the
    org.springframework.flex_1.0.0.RELEASE bundle currently available in the springsource bundle repository the spring framework dependencies
    can not be resolved.

    Is there a milestone version availabe that uses spring 3 already ?

    It seems to me that the manifest entries do match 3.0.0 only but not 3.0.0.M4.

    Any help appreciated.

    Regards,
    Dirk

  • #2
    The existing project works with Spring 3.0...it was just an oversight that we did not expand the version range in the OSGi manifest. This has been fixed for 1.0.1. You can obtain the fix in the latest 1.0.1 nightly builds here: http://static.springframework.org/do...p?project=FLEX. We will be releasing 1.0.1 at some point this week.

    Comment


    • #3
      Thanks Jeremy for the hint.
      With the 1.0.1 Version of the spring flex bundle I get the following error during the spring context initialization of my web bundle

      Caused by: java.lang.NoClassDefFoundError: org/w3c/dom/traversal/NodeIterator
      at org.apache.xpath.XPathContext.<init>(XPathContext. java:1031)
      at org.apache.xpath.CachedXPathAPI.<init>(CachedXPath API.java:73)
      at flex.messaging.config.ApacheXPathServerConfigurati onParser.initializeExpressionQuery(ApacheXPathServ erConfigurationParser.java:43)
      at flex.messaging.config.AbstractConfigurationParser. parse(AbstractConfigurationParser.java:68)

      I added a
      Require-Bundle: org.springframework.flex; bundle-version="1.0.1.CI-272"

      to my web bundle manifest, but the org.w3c.dom.traversal is not imported by any of the depending bundles. Shouldn't this package be imported by the
      com.springsource.flex.messaging bundle ?

      Regards,
      Dirk

      Comment

      Working...
      X