Announcement Announcement Module
Collapse
No announcement yet.
Which jars exactly are needed for Flex/Blaze DS? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Which jars exactly are needed for Flex/Blaze DS?

    Hi,

    We have a webapp running on glassfish with a flex front-end and spring on the server-side. We would like to add Blaze DS to the app but are not sure exactly which jars are needed. Presently we have included these in addition to our other jars:
    cglib-2.1.jar
    cfgatewayadapter.jar
    flex-messaging-common.jar
    flex-messaging-core.jar
    flex-messaging-opt.jar
    flex-messaging-proxy.jar
    flex-messaging-remoting.jar
    jackson-core-lgpl-1.0.0.jar
    jackson-jaxrs-1.0.0.jar
    jackson-mapper-lgpl-1.0.0.jar
    org.springframework.flex-1.0.0.RC2.jar
    spring-webmvc.jar
    spring.jar
    xalan.jar
    xercesImpl.jar
    xml-apis.jar
    xpp3-1.1.3.4.C.jar
    xsltc.jar
    xstream-1.2.jar

    Currently we are getting this exception:
    Code:
    java.lang.NoSuchMethodError: org.apache.xpath.XPathContext.<init>(Z)V
    	at org.apache.xpath.CachedXPathAPI.<init>(CachedXPathAPI.java:77)
    Rather than continuing down the path of adding jars to make exceptions go away, can someone provide a comprehensive list of all jars needed?
Working...
X