Announcement Announcement Module
Collapse
No announcement yet.
Announcements: SBI 1.5.0 GA Released Page Title Module
Move Remove Collapse
This is a sticky topic.
X
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • jeremyg484
    started a topic Announcements: SBI 1.5.0 GA Released

    Announcements: SBI 1.5.0 GA Released

    I'm pleased to announce that the 1.5.0 GA release of Spring BlazeDS Integration is now available.

    See the official release announcement for more details.
    Last edited by jeremyg484; Jun 28th, 2011, 02:29 PM.

  • jeremyg484
    replied
    See the top post for the release info for Spring BlazeDS Integration 1.5.0 GA.

    Leave a comment:


  • MikeOliverAZ
    replied
    bingo we have a winner

    Jeremy,

    Added...

    <repository>
    <id>org.springframework.maven.milestone</id>
    <name>Maven Central Compatible Spring Milestone Repository</name>
    <url>http:// maven.springframework.org/milestone</url>
    </repository>

    to the spring-flex-core/pom.xml in STS and that triggered the maven synch, then I did a Maven Install in the "Run As" and it did its thing.

    I guess my question is, why doesn't the distro have this in the pom already? Isn't that the only place to get the proper dependencies? I know that when it goes into production the milestones will be removed, but when you go into production release why not remove this from the pom on the final distro?

    Leave a comment:


  • jeremyg484
    replied
    Originally posted by MikeOliverAZ View Post
    I don't know what you mean by, "then the easiest thing to do is go one level up (to the main spring-flex directory)" as in the -dist, the spring-flex-core is in a directory all by itself and no pom in the directory above it anyplace.
    Ahh right, sorry, I said that without actually looking at the distro. In that case you would either need to build from SVN, or point to the Spring milestones repo so that it will pull the parent pom.

    Leave a comment:


  • MikeOliverAZ
    replied
    The only reason I was building spring-flex-core was so that I could use it as a reference from other projects, and I had a similar problem after importing the testdrive sample.

    I don't know what you mean by, "then the easiest thing to do is go one level up (to the main spring-flex directory)" as in the -dist, the spring-flex-core is in a directory all by itself and no pom in the directory above it anyplace.

    I am trying to do mvn install in the samples/spring-flex-testdrive/

    It does look like it is synching the M2_REPO so perhaps that will do the trick.

    Leave a comment:


  • jeremyg484
    replied
    Well, typically you shouldn't need to build spring-flex-core yourself at all, unless you are trying to make changes to it. I would expect the more common case to be only importing and building the Test Drive, as that's the one we try to ensure works out-of-the-box.

    That said, if you really do need to build spring-flex-core, then the easiest thing to do is go one level up (to the main spring-flex directory) and execute 'mvn install' from there. This will ensure the parent POM gets published to your local repo as well.

    Alternatively, you can just point to the Spring milestones maven repo in your settings.xml.

    Leave a comment:


  • MikeOliverAZ
    replied
    spring-flex-core in 1.5.0.RC1 fails to build with maven

    spring-flex-core build gives


    Code:
    [INFO] Scanning for projects...
    Downloading: http://repo1.maven.org/maven2/org/springframework/flex/spring-flex-parent/1.5.0.RC1/spring-flex-parent-1.5.0.RC1.pom
    [INFO] Unable to find resource 'org.springframework.flex:spring-flex-parent:pom:1.5.0.RC1' in repository central (http://repo1.maven.org/maven2)
    [INFO] ------------------------------------------------------------------------
    [ERROR] FATAL ERROR
    [INFO] ------------------------------------------------------------------------
    [INFO] Error building POM (may not be this project's POM).

    Leave a comment:


  • MikeOliverAZ
    replied
    Are there installation instructions? I imported the spring-flex-core and testdrive projects into STS 2.6.1 and tried a maven install and got


    Unable to find resource 'org.springframework.flex:spring-flex-parentom:1.5.0.RC1' in repository central (http://repo1.maven.org/maven2)

    Leave a comment:


  • jeremyg484
    replied
    See the top post for the release info for Spring BlazeDS Integration 1.5.0.RC1.

    Leave a comment:


  • MikeOliverAZ
    replied
    LCDS Integration Udate???

    Originally posted by jeremyg484 View Post
    I'll be meeting with folks from Adobe at MAX in a couple of weeks to figure out the exact direction here. Within the next week, we'll be moving the current trunk to a 1.0.x maintenance branch so that we can begin work in earnest on what we're currently calling 1.5, which will include the explicit LCDS integration. One of the first things we'll do is commit some of the initial work we've done previously (when we thought it would not be able to be open source) for LCDS integration, so you'll be able to see some of this functionality in the nightly builds very soon.
    As this is quite old, does "very soon" still apply. Yes very interested.

    Leave a comment:


  • MikeOliverAZ
    replied
    http://www.springframework.org/schema/flex/spring-flex-1.5.xsd DOES NOT EXIST

    Originally posted by jeremyg484 View Post
    I'm pleased to announce that the 1.5.0.M2 milestone release of Spring BlazeDS Integration is now available. A 1.0.0.M2 release of the Flex Addon for Spring Roo should follow over the coming weeks.

    See the official release announcement for more details.
    The flex-servlet.xml included in the above distribution /testdrive/WEB-INF/ references http://www.springframework.org/schema/flex/spring-flex-1.5.xsd which does not exist while http://www.springframework.org/schema/flex/spring-flex-1.0.xsd does exist.

    Leave a comment:


  • MikeOliverAZ
    replied
    testdrive servlet.xml errors

    Originally posted by MikeOliverAZ View Post
    Ok I downloaded 1.5.0.M2, but the readme didn't explain how to install it in STS 2.5.2

    is it just put the 1.5.0.M2 jar in one of the STS RELEASE folders like dropins, features, or plugins?
    I imported the testdrive projects and maven did a good job of populating the M2_REPO.

    but still have a bunch of errors in servlet.xml and most are similar to

    cvc-complex-type.2.4.c: The matching wildcard is strict, but no declaration can be found for element 'flex:integration-message-destination'.

    which tells me the integration isn't complete.

    Leave a comment:


  • MikeOliverAZ
    replied
    Testdrive documentation correction

    The doucmenation on building and trying the BlazeDS testdrive projects, has an ambiguous paragraph that led me down the primrose path.

    It says...

    To import the samples, select File->Import...->General->Existing Projects into Workspace and navigate to the {project distribution root}/spring-flex-samples/spring-flex-testdrive directory and import all of the projects found.

    what it really should say is...

    To import the samples, select File->Import...->Maven->Existing Maven Projects into Workspace and navigate to the {project distribution root}/spring-flex-samples/spring-flex-testdrive directory and import all of the projects found.

    If you do that then all the dependencies and your local repository at the M2_REPO variable will be resolved and it will all work fine...do it they General existing projects and you have to do it all manually. (at least I did)

    Leave a comment:


  • MikeOliverAZ
    replied
    testdrive missing artifacts

    I followed Jeremy's directions and ran

    mvn clean install in the M2 dist samples testdrive folder. It ran for a long time with no errors, cool!

    I then went to STS 2.5.2 and imported the existing project testdrive from the above folder. The build of the project in STS 2.5.2 failed and a quick check of the build path shows a lot of red x's in the build path under the M2_REPO variable. See below.

    http://dl.dropbox.com/u/249163/image...19%2012.38.jpg

    I tried cleaning the project and build all but no change.

    Leave a comment:


  • MikeOliverAZ
    replied
    Ok I downloaded 1.5.0.M2, but the readme didn't explain how to install it in STS 2.5.2

    is it just put the 1.5.0.M2 jar in one of the STS RELEASE folders like dropins, features, or plugins?

    Leave a comment:

Working...
X