Announcement Announcement Module
Collapse
No announcement yet.
Unable to create a ROO Flex project with Flex version 4.5 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to create a ROO Flex project with Flex version 4.5

    Dear Experts

    Greeting for the day, today i was trying to get my hands dirty with ROO in Flex but i am getting following errors -
    -------------------------------------------------------------------------------------------------------------
    Welcome to Spring Roo. For assistance press TAB or type "hint" then hit ENTER.
    roo> ERROR: Error starting file:/D:/springsource/spring-roo-1.1.5.RELEASE/bundle
    /spring-flex-core-1.5.2.RELEASE.jar (org.osgi.framework.BundleException: Unresol
    ved constraint in bundle org.springframework.flex [67]: Unable to resolve 67.0:
    missing requirement [67.0] package; (&(package=flex.management)(version>=4.0.0)(
    !(version>=4.1.0))))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr
    amework.flex [67]: Unable to resolve 67.0: missing requirement [67.0] package; (
    &(package=flex.management)(version>=4.0.0)(!(versi on>=4.1.0)))
    at org.apache.felix.framework.Felix.resolveBundle(Fel ix.java:3409)
    at org.apache.felix.framework.Felix.startBundle(Felix .java:1719)
    at org.apache.felix.framework.Felix.setActiveStartLev el(Felix.java:1148)

    at org.apache.felix.framework.StartLevelImpl.run(Star tLevelImpl.java:264
    )
    at java.lang.Thread.run(Unknown Source)
    [org.springframework.flex [67]] FrameworkEvent ERROR
    org.apache.felix.log.LogException: org.osgi.framework.BundleException: Unresolve
    d constraint in bundle org.springframework.flex [67]: Unable to resolve 67.0: mi
    ssing requirement [67.0] package; (&(package=flex.management)(version>=4.0.0)(!(
    version>=4.1.0)))
    at org.apache.felix.framework.Felix.resolveBundle(Fel ix.java:3409)
    at org.apache.felix.framework.Felix.startBundle(Felix .java:1719)
    at org.apache.felix.framework.Felix.setActiveStartLev el(Felix.java:1148)
    at org.apache.felix.framework.StartLevelImpl.run(Star tLevelImpl.java:264)
    at java.lang.Thread.run(Unknown Source)
    0 upgrades available (plus 29 upgrades not visible due to your version stability
    setting of RELEASE)
    -------------------------------------------------------------------------------------------------------------


    Where i am using -

    1) sts-2.8.1.RELEASE
    2) spring-roo-1.1.5.RELEASE
    3) Adobe Flash Builder 4.5
    4) spring-flex-core-1.5.2.RELEASE
    5) org.springframework.flex.roo.addon-1.0.0.BUILD-20110219.075648-225

    I have followed every step of setting up environment, shown by "John Grelle" in his you tube video to create a flex project but getting above error, i guess the error is popping up due to my flex version but not sure (if the flex version is issue than is there any way through which i can carry on with my new flex version).

    Any help is highly appreciable.


    Thanks and regards,

    Varun Bajaj
Working...
X