Announcement Announcement Module
Collapse
No announcement yet.
Spring BlazeDS - Remote Call doesn't work Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring BlazeDS - Remote Call doesn't work

    Hi,

    I have application using Spring 3 Flex 3 and Spring Blazeds Integration 1.3 version. My application works perfrectly fine when I deploy it on Weblogic or Tomocat. However, In my organizaion, I need to access it through portal so I have to configure a URL in portal. They need proxy server URL. I can not give directly my Weblogic Server URL. So I have configured Sun Java Web Server and configured application in it so it redirects to my application URL.

    When I access the application through Portal, I can see the Flex application but it is not able to make any remote call. It just keeps on processing and I don't see any log in my application server log file. Below is my configuration. Pointer to resolve the issue will be appreciated.

    remoting-config.xml
    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <service id="remoting-service" 
        class="flex.messaging.services.RemotingService">
    
        <adapters>
            <adapter-definition id="java-object" class="flex.messaging.services.remoting.adapters.JavaAdapter" default="true"/>
        </adapters>
    
        <default-channels>
         	<channel ref="my-amf"/>
            <channel ref="my-secure-amf"/>
        </default-channels>
      
    </service>
    proxy-config.xml
    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <service id="proxy-service" 
        class="flex.messaging.services.HTTPProxyService">
    
        <properties>
            <connection-manager>
                <max-total-connections>100</max-total-connections>
                <default-max-connections-per-host>2</default-max-connections-per-host>
            </connection-manager>
            <allow-lax-ssl>true</allow-lax-ssl>
        </properties>
    
        <adapters>
            <adapter-definition id="http-proxy" class="flex.messaging.services.http.HTTPProxyAdapter" default="true"/>
            <adapter-definition id="soap-proxy" class="flex.messaging.services.http.SOAPProxyAdapter"/>
        </adapters>
    
        <default-channels>
            <channel ref="my-amf"/>
            <channel ref="my-secure-amf"/>
        </default-channels>
    
        <destination id="DefaultHTTP">
        </destination>
    
    </service>

    service-config.xml
    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <services-config>
    
        
        <services>
            <service-include file-path="remoting-config.xml" />
            <service-include file-path="proxy-config.xml" />        
            <default-channels>
               <channel ref="my-amf"/>
                <channel ref="my-secure-amf"/>
            </default-channels>
        </services>
        
    
        <channels>
            <channel-definition id="my-amf" class="mx.messaging.channels.AMFChannel">
                <endpoint url="http://{server.name}:{server.port}/{context.root}/messagebroker/amf" class="flex.messaging.endpoints.AMFEndpoint"/>
            </channel-definition>
         
            <channel-definition id="my-secure-amf" class="mx.messaging.channels.SecureAMFChannel">
                <endpoint url="https://{server.name}:{server.port}/{context.root}/messagebroker/amfsecure" class="flex.messaging.endpoints.SecureAMFEndpoint"/>
                <properties>
                    <add-no-cache-headers>false</add-no-cache-headers>
                </properties>
            </channel-definition>
            
            <channel-definition id="my-secure-polling-amf" class="mx.messaging.channels.AMFChannel">
                <endpoint url="https://{server.name}:{server.port}/{context.root}/messagebroker/amfpolling" class="flex.messaging.endpoints.AMFEndpoint"/>
                <properties>
                    <polling-enabled>true</polling-enabled>
                    <polling-interval-seconds>4</polling-interval-seconds>
                </properties>
            </channel-definition>
            
            <channel-definition id="my-longpolling-amf" class="mx.messaging.channels.AMFChannel">
    			<endpoint url="http://{server.name}:{server.port}/{context.root}/app/messagebroker/amflongpolling" class="flex.messaging.endpoints.AMFEndpoint"/>
    			<properties>
    				<polling-enabled>true</polling-enabled>
                    <polling-interval-millis>8000</polling-interval-millis>
                    <piggybacking-enabled>true</piggybacking-enabled>
                    <wait-interval-millis>60000</wait-interval-millis>
                    <client-wait-interval-millis>1</client-wait-interval-millis>
                    <max-waiting-poll-requests>200</max-waiting-poll-requests>			
    			</properties>
    		</channel-definition>
    		
    		<channel-definition id="my-streaming-amf" class="mx.messaging.channels.StreamingAMFChannel">
                <endpoint url="http://{server.name}:{server.port}/{context.root}/app/messagebroker/streamingamf" class="flex.messaging.endpoints.StreamingAMFEndpoint"/>
            </channel-definition>    
    
         </channels>
         
         <logging>
            <target class="flex.messaging.log.ConsoleTarget" level="Info">
                <properties>
                    <prefix>[BlazeDS] </prefix>
                    <includeDate>false</includeDate>
                    <includeTime>false</includeTime>
                    <includeLevel>false</includeLevel>
                    <includeCategory>false</includeCategory>
                </properties>
                <filters>
                    <pattern>Endpoint.*</pattern>
                    <pattern>Service.*</pattern>
                    <pattern>Configuration</pattern>
                </filters>
            </target>
        </logging>
    
        <system>
        	<manageable>false</manageable>
            <redeploy>
                <enabled>false</enabled>
                <!-- 
                <watch-interval>20</watch-interval>
                <watch-file>{context.root}/WEB-INF/flex/services-config.xml</watch-file>
                <watch-file>{context.root}/WEB-INF/flex/proxy-config.xml</watch-file>
                <watch-file>{context.root}/WEB-INF/flex/remoting-config.xml</watch-file>
                <watch-file>{context.root}/WEB-INF/flex/messaging-config.xml</watch-file>
                <watch-file>{context.root}/WEB-INF/flex/data-management-config.xml</watch-file>
                <touch-file>{context.root}/WEB-INF/web.xml</touch-file>
                 -->
            </redeploy>
        </system>
          
    
    </services-config>

    bean-config.xml
    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <beans xmlns="http://www.springframework.org/schema/beans" 
    	xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
        xmlns:flex="http://www.springframework.org/schema/flex"
    	xsi:schemaLocation="http://www.springframework.org/schema/beans
          http://www.springframework.org/schema/beans/spring-beans-2.5.xsd
          http://www.springframework.org/schema/flex 
    	  http://www.springframework.org/schema/flex/spring-flex-1.0.xsd">
     
    	<flex:message-broker>
            <flex:remoting-service default-channels="my-secure-amf, my-amf"/>
            <flex:message-service default-channels="my-secure-polling-amf, my-longpolling-amf"/>
            
        </flex:message-broker>
    
    	
    	<flex:remoting-destination ref="AdminController" destination-id="AdminController"/> 
    	
    <flex:jms-message-destination id="UIEventDestination" jms-destination="updateTopic" /> 
    
    	
    		
    </beans>
Working...
X