Announcement Announcement Module
Collapse
No announcement yet.
Trouble locating form TLD Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Trouble locating form TLD

    I have an application working perfectly in DEV (on Tomcat). But when I try to migrate it to a jBoss test server I get the error:

    Code:
    The absolute uri: http://www.springframework.org/tags/form cannot be resolved in either web.xml or the jar files deployed with this application
    The puzzling thing is that I have org.springframework.web-3.0.2.RELEASE.jar, org.springframework.web.servlet-3.0.2.RELEASE.jar and spring-security-taglibs-3.0.2.RELEASE.jar in the classpath (I know that the TLD is supposed to be in one of those).

    I can fix the problem by creating WEB-INF/tld and adding adding spring-form.tld to it, but it "feels wrong". If the app works without it on Tomcat, it should work on jBoss!

    Curiously enough, I experience a similar issue with a totally unrelated technology. In Tomcat I don't need to put the sitemesh JAR in WEB-INF/lib so long as it is in the classpath, but in jBoss it gets ignored the same way as spring-form.tld. No other jars or tlds seem to have this problem.

    Is there something that I might be missing on jBoss?
    Last edited by bmelloni; Mar 10th, 2011, 12:39 PM. Reason: Additional info

  • #2
    did you figure it out?

    I have the same problem.

    Comment

    Working...
    X