Announcement Announcement Module
Collapse
No announcement yet.
Problem with Books sample portlet on JBoss Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with Books sample portlet on JBoss

    Just as a quick test I'm trying to evaluate the upcoming support for portlets. I downloaded the sample portlets from http://opensource2.atlassian.com/con...ay/JSR168/Home and added the JBoss specific deployment descriptors. During the first attempt, both the mode and books samples died with a PortletException that the controller did not handle action requests.

    So I took the BooksController, and added the missing handleActionRequestInternal method, and sure enough the portlet rendered just fine. However, when I hit the refresh button on the browser, JBoss threw a HTTP 500 server error:


    Code:
    javax.servlet.ServletException: Unknown result org.jboss.portal.server.output.FragmentResult@9d52ac
    	org.jboss.portal.core.servlet.CoreServlet.render(CoreServlet.java:223)
    	org.jboss.portal.server.servlet.AbstractMainServlet.invoke(AbstractMainServlet.java:81)
    	org.jboss.portal.server.servlet.AbstractMainServlet.doGet(AbstractMainServlet.java:71)
    	javax.servlet.http.HttpServlet.service(HttpServlet.java:697)
    	javax.servlet.http.HttpServlet.service(HttpServlet.java:810)
    ... (shortened for brevity)
    Has anybody else tried to deploy the samples in JBoss? I've tried both 4.0 and 4.01RC1 with the same results. I suspect it's some sort of badness in JBoss itself, but haven't had time to track it down yet. The interesting part is that if you wait at least 30 seconds and then hit reload, it works just fine. Also, I see the same behaviour when submitting the form on the Add Book page - if I don't wait 30 seconds, it throws the exact same exception.

  • #2
    Problem "solved". Looks like the problem is with the expiration-cache settings in portlet.xml. I commented out the line:

    <!-- <expiration-cache>60</expiration-cache> -->

    for the books portlet, and it no longer throws the exception, so it looks like a JBoss problem.

    Comment


    • #3
      Interesting JBoss Bug

      Glad you found that. I will simplify the example code and remove the expiration cache setting. Did you report the problem to the JBoss gang?

      Comment

      Working...
      X