Announcement Announcement Module
Collapse
No announcement yet.
Is JSTL functions (fn) supported in Spring MVC? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Is JSTL functions (fn) supported in Spring MVC?

    I tried installing the latest version of Jakarta standard.jar but got an exception with Spring.

    I'm trying to use the JSTL functions (fn.tld) stuff for trimming strings.

    Has anyone successfuly used this with Spring MVC?

  • #2
    AFAIK there is no reason why it shouldn't work.

    What exception do you get?

    Comment


    • #3
      Yes. I'm using the fn: functions.

      Comment


      • #4
        It's probably the version of your server. I had problems with an earlier Weblogic 8.1 release.

        Comment


        • #5
          Thanks, everyone for your replies.

          First, I'm using WebLogic 8.1 SP4.

          Second, here is the exception shown in the browser:
          Code:
          /test.jsp(1): Error in using tag library uri='/WEB-INF/fn.tld' prefix='fn': Tag Library Descriptor contains no Tag descriptions
          probably occurred due to an error in /test.jsp line 1:
          <%@ taglib prefix="fn" uri="/WEB-INF/fn.tld" %>
          Third, here are my code excerpts:
          Code:
          <%@ taglib prefix="fn" uri="/WEB-INF/fn.tld" %>
          <h1>'<c&#58;out value="$&#123;fn&#58;trim&#40;'  MYSTRING  '&#125;"/>'</h1>

          Comment


          • #6
            P.S. I just deployed the standard-examples.war from the jakarta-taglibs-standard-1.1.2 download and got the same error:

            Code:
            /functions/Trim.jsp&#40;2&#41;&#58; Error in using tag library uri='http&#58;//java.sun.com/jsp/jstl/functions' prefix='fn'&#58; Tag Library Descriptor contains no Tag descriptions
            probably occurred due to an error in /functions/Trim.jsp line 2&#58;
            <%@ taglib prefix="fn" uri="http&#58;//java.sun.com/jsp/jstl/functions" %>
            Since WebLogic 8.1 SP4 only supports these versions, does that mean, I cannot use the "fn" functions?
            Servlet 2.3 and 2.2
            JSP 1.2 and 1.1

            Comment

            Working...
            X