Announcement Announcement Module
Collapse
No announcement yet.
Spring Tutorial, Build Failed, http://localhost:8080/manager/list 404 Error Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring Tutorial, Build Failed, http://localhost:8080/manager/list 404 Error

    Hi,

    I have set up tomcat and eclipse. Starting tomcat via eclipse I can access the localhost:8080/ tomcat wellcome page.

    But when I run list after the deploy commad I get the following error:

    Buildfile: C:\Users\Artjom\Desktop\xy_ids\xy_ids\build.xml
    usage:
    [echo] neargear_ids build file
    [echo] -----------------------------------
    [echo] Available targets are:
    [echo] build --> Build the application
    [echo] deploy --> Deploy application as directory
    [echo] deploywar --> Deploy application as a WAR file
    [echo] install --> Install application in Tomcat
    [echo] reload --> Reload application in Tomcat
    [echo] start --> Start Tomcat application
    [echo] stop --> Stop Tomcat application
    [echo] list --> List Tomcat applications
    build:
    deploy:
    list:

    BUILD FAILED
    C:\Users\Artjom\Desktop\xy_ids\xy_ids\build.xml:13 3: java.io.FileNotFoundException: http://localhost:8080/manager/list

    Total time: 160 milliseconds


    the information in tomcat_user.xml and in build.properties in regards to the user informaition are equal.

    please help

  • #2
    could you pls post your complete build.xml file as well. that may give some more clear picture of how you have configured it. I am sure there is something wrong with your welcome file. check the redirection tag if you are redirecting it

    Comment


    • #3
      are you trying to build spring step by step application. which app are you trying let me know pls.

      Comment


      • #4
        Step 1.4 in Spring Tutorial

        Comment


        • #5
          my friend you are getting that error because build.properties file which you have copied is not pointing to proper location of your tomcat_home directory. make sure you have tomcat_home path set.
          Also which tomcat version are you using if 5.5 then point to lib dir.

          Comment


          • #6
            build.properties
            # Ant properties for building the neargear app

            appserver.home=c:/apache_tomcat
            # for Tomcat 5 use $appserver.home}/server/lib
            # for Tomcat 6 use $appserver.home}/lib
            appserver.lib=${appserver.home}/lib

            deploy.path=${appserver.home}/webapps

            tomcat.manager.url=http://localhost:8080/manager
            tomcat.manager.username=tomcat
            tomcat.manager.password=s3cret


            I do not see the problem in build.properties. I use Tomcat 6

            Comment


            • #7
              Try following steps :-
              1) localhost:8080/manager working? are you able to login as a manager?
              2) have you downloaded the correct tomcat zip file?
              3) in your tomcat installation drive check conf/tomcat-users.xml and add following lines:
              <?xml version='1.0' encoding='utf-8'?>
              <tomcat-users>
              <role rolename="manager"/>
              <role rolename="admin"/>
              <user username="tomcat" password="s3cret" roles="admin,manager"/>
              </tomcat-users>
              4) if still not working i am sure there is something wrong with your tomcat check this link http://www.coderanch.com/t/109089//ant-list-error
              also check http://www.coreservlets.com/Apache-Tomcat-Tutorial/
              for tomcat help.
              hope this helps

              Comment


              • #8
                1. manager doent work, getting 404 error
                2. I used eclipse to install tomcat
                3. conf/tomcat-users.xml and the tomcat-users.xml in eclipse have different content

                should I install tomcat without eclipse first?

                Comment


                • #9
                  ya that's true. I did expected it. Manager will not work you are missing a few jar files.
                  Using tomcat inside eclipse gives you a different behavior, thats because eclipse will use instance of tomcat app.
                  If you are a fan of eclipse like me then follow these simple steps, this is just a tool to use command prompt inside eclipse! In your eclipse Help button there is a install new software option add the following plugin it will install automatically.
                  name: Wicked Shell
                  update url: http://www.wickedshell.net/updatesite

                  then download tomcat from http://tomcat.apache.org/download-60.cgi download binary distribution in .zip format and extract it and place it somewhere in c or d drive. make sure you point in build.properties file.

                  next step is to configure tomcat: in your System properties (Windows OS) there is environment variable setting add a new variable with following in both user and system variables :
                  variable name: TOMCAT_HOME
                  value: C:\work\apache-tomcat-6.0.26

                  you need to configure a manager in conf dir. as i mentioned in my previous post.

                  next go to your folder where you have extracted tomcat. If everything is ok then you will find C:\work\apache-tomcat-6.0.26\bin "startup.bat" double click it. tomcat will startup.

                  next modify your build.properties accordingly.

                  Comment


                  • #10
                    when I double click on startup the cmd appears for one secounds and I have no chance to recognice whats written there. tomcat doesnt start

                    Comment


                    • #11
                      pls set up environment variables properly in both user as well as system.

                      Comment


                      • #12
                        i am assuming that you are aware of class path concepts and how to set environment variables.

                        Comment


                        • #13
                          Hi,

                          tomcat is running now, I can login as admin and manager. But if I start Tomcat via eclipse, the browser shows an 404 error. Only when I start it by doubleclicking on startup.bat tomcat works...

                          ps: the solution to get tomcat running was to set the JAVA_HOME path in the environment variables of my windows 7 x64

                          Comment


                          • #14
                            deploy and list is successful now:

                            Buildfile: C:\Users\Artjom\Desktop\xy\xy\build.xml
                            usage:
                            [echo] xy build file
                            [echo] -----------------------------------
                            [echo] Available targets are:
                            [echo] build --> Build the application
                            [echo] deploy --> Deploy application as directory
                            [echo] deploywar --> Deploy application as a WAR file
                            [echo] install --> Install application in Tomcat
                            [echo] reload --> Reload application in Tomcat
                            [echo] start --> Start Tomcat application
                            [echo] stop --> Stop Tomcat application
                            [echo] list --> List Tomcat applications
                            build:
                            deploy:
                            [copy] Copying 13 files to c:\tomcat\webapps\xy
                            list:[list] OK - Listed applications for virtual host localhost[list] /:running:0:ROOT[list] /manager:running:1:manager[list] /docs:running:0:docs[list] /examples:running:0:examples[list] /host-manager:running:0:host-manager
                            BUILD SUCCESSFUL
                            Total time: 183 milliseconds


                            the only thing I did is starting and stopping tomcat via startup.bat/shutdown.bat and not using eclipse for this job.

                            thank you for your help

                            Comment


                            • #15
                              Hi,

                              Now I have another build failure:

                              Buildfile: C:\Users\Artjom\Desktop\neargear_ids\neargear_ids\ build.xml
                              usage:
                              [echo] neargear_ids build file
                              [echo] -----------------------------------
                              [echo] Available targets are:
                              [echo] build --> Build the application
                              [echo] deploy --> Deploy application as directory
                              [echo] deploywar --> Deploy application as a WAR file
                              [echo] install --> Install application in Tomcat
                              [echo] reload --> Reload application in Tomcat
                              [echo] start --> Start Tomcat application
                              [echo] stop --> Stop Tomcat application
                              [echo] list --> List Tomcat applications
                              build:
                              [javac] Compiling 1 source file to C:\Users\Artjom\Desktop\neargear_ids\neargear_ids\ war\WEB-INF\classes

                              BUILD FAILED
                              C:\Users\Artjom\Desktop\neargear_ids\neargear_ids\ build.xml:45: C:\Users\Artjom\Desktop\neargear_ids\neargear_ids\ war\WEB-INF\lib not found.

                              Total time: 146 milliseconds


                              the only thing I did was extending my project with some libs.

                              http://img571.imageshack.us/img571/5104/libs.png

                              please help

                              Comment

                              Working...
                              X