Announcement Announcement Module
Collapse
No announcement yet.
Runtime Req. for Spring 1.2.1 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Runtime Req. for Spring 1.2.1

    I downloaded the current production version 1.2.1 with dependencies. The Release Info states that:

    The Spring Framework requires J2SE 1.3 and J2EE 1.3 (Servlet 2.3, JSP 1.2, JTA 1.0, EJB 2.0). J2SE 1.4 is
    required for building the framework; for the full build including Tiger support, J2SE 5.0 is required.
    J2EE 1.2 (Servlet 2.2, JSP 1.1) is sufficient when not using Spring's JSP tag libraries or the EJB support.
    The RAEDME.txt in the LIB directory states:


    * j2ee/jsp-api.jar
    - JSP API 2.0 (http://java.sun.com/products/jsp)
    - required for building the framework
    - required at runtime when using Spring's JSP support

    * j2ee/servlet-api.jar
    - Servlet API 2.4 (http://java.sun.com/products/servlet)
    - required for building the framework
    - required at runtime when using Spring's web support
    Is there a conflict here? If yes, how can I resolve it?

    I noticed that building classes in the org.springframework.mock package only works when JSP 2.0 and Servlet 2.4 jar's are in the classpath.

    I am deploying on Weblogic 8.1 SP1 that supports JSP 1.2 and Servlet 2.3. Will I run into problems deploying my application on Weblogic 8.1?

    Rgrds, Thomas

  • #2
    I've had no trouble running the Spring Web MVC samples on WLS 8.1 SP4. Just make sure to build your application using the Servlet 2.3/JSP 1.2 APIs (e.g. by using weblogic.jar at build time).

    Comment


    • #3
      Then maybe this is a bug in the docu?

      Comment


      • #4
        I'd call it an inconsistency. :wink:

        Comment

        Working...
        X