Announcement Announcement Module
Collapse
No announcement yet.
Do Authz tags require a JSP 2.0 Container? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Do Authz tags require a JSP 2.0 Container?

    I used Acegi 0.6.0 Authz tags successfully in Tomcat 5.0 and now I'm trying to use 0.8.1 in Websphere Application Server 5.0 but am getting the following error:

    Code:
    [5/18/05 12:34:49:085 EDT] 41604160 ExpressionEva I org.springframework.web.util.ExpressionEvaluationUtils  Using Jakarta JSTL ExpressionEvaluatorManager
    
    [5/18/05 12:34:49:586 EDT] 41604160 WebGroup      E SRVE0026E: [Servlet Error]-[java/lang/String.replaceAll(Ljava/lang/String&#59;Ljava/lang/String&#59;)Ljava/lang/String&#59;]: java.lang.NoSuchMethodError: java/lang/String.replaceAll(Ljava/lang/String;Ljava/lang/String;)Ljava/lang/String;
    	at java.lang.Throwable.<init>&#40;Throwable.java&#41;
    	at java.lang.Throwable.<init>&#40;Throwable.java&#41;
    	at java.lang.NoSuchMethodError.<init>&#40;NoSuchMethodError.java&#58;56&#41;
    	at net.sf.acegisecurity.taglibs.authz.AuthorizeTag.parseAuthoritiesString&#40;AuthorizeTag.java&#58;163&#41;
    	at net.sf.acegisecurity.taglibs.authz.AuthorizeTag.doStartTag&#40;AuthorizeTag.java&#58;109&#41;
    	at org.apache.jsp._mainMenu._jspService&#40;mainMenu.jsp  &#58;38&#41;
    When I check the Javadoc for org.springframework.web.util.ExpressionEvaluationU tils
    (http://www.springframework.org/docs/...tionUtils.html) it says that Jakarta's JSTL implementation is used if JSP 2.0 support is not found. However, I wonder if it's trying to fall back to Jakarta's JSTL 1.1 instead of 1.0. I believe only 1.0.x will run within Websphere's older JDK 1.3 environment. Switching to a JSP 2.0 container isn't an option for this project.

    Your thoughts on how I could use the Authz tags or another workaround?

    Thanks in advance,
    Scott

  • #2
    Because we're delegating to org.springframework.util.StringUtils, I'll move this thread across to the web forum where it'll get more focused exposure.

    Comment


    • #3
      Thanks Ben.

      Anyone?

      TIA, Scott

      Comment


      • #4
        Well, the problem is a method that doesn't exist. String.replaceAll() is available on J2SE 1.4 or better, I believe.

        What is the compatibility policy of Acegi Security System ?

        If you can, simply submit a patch which does not use String.replaceAll(), but does the same thing iteratively.

        Hope that helps,
        François

        Comment


        • #5
          Opened SEC-11 http://opensource.atlassian.com/proj.../browse/SEC-11.

          Thanks,
          Scott

          Comment


          • #6
            SEC-11 is now resolved and will be released in 0.9.0 so that Authz tags can be used with J2SE 1.3 (like Websphere 5.0).

            Comment


            • #7
              Can I use ACEGI with JRE 1.3.1 and JSP 1.1 like WAS 4.0.6?

              I understand I cannot use the javax.servlet.Filter class, but can I use the authentification taglib?

              Thanks

              Etienne.

              Comment


              • #8
                I haven't tried it, but yes, the authz taglib should work within WAS 4.

                Comment

                Working...
                X