Announcement Announcement Module
Collapse
No announcement yet.
Tomcat [ERROR] SchemaExecute update Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Tomcat [ERROR] SchemaExecute update

    Hello,

    I have a big problem. (i use equinox : hsqldb, hibernate, spring and JSF).

    I do the server and web side to link user and company tables ...
    JUnit, JWebUnit, Canoo Tests works fine ..

    But ... i deploy my project ... and when i run
    tomcat, i obtain this error :

    "SchemaUpdate.execute : Unsuccessful alter table .. constraint ...."
    and
    "SchemaUpdate.execute : Column types do not match ..."

    Why when i run test all works, and why when i run tomcat i obtain
    these errors ?

    if I puts the following line:

    Code:
    <prop key="hibernate.hbm2ddl.auto">create</prop>
    in applicationContext file, when i deploy my web application ...

    I have an error at the time of the initialization of Tomcat, i obtains
    a NullPointerException at java.util.hashtable.puts..., at
    org.hsqldb.TableWorks ....

    Tomcat don't want to create the table which i added a "foreign key",
    after i obtains ERROR for SchemaExport.execute ...

    Can you help me? Because it's an error very very irritating .

    I thinks it's easy to link tables with hsqldb and equinox, i do all
    the things that i must do in hsqldb, hibernate, spring and jsf ...
    But when i run tomcat i obtains these errors, and i am tired about this errors.

    So, if you could help me, I would be eternally grateful to you .

    Bye[/code]
Working...
X