Announcement Announcement Module
Collapse
No announcement yet.
Portlet Question Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Portlet Question

    Hello All,

    I am very new to Spring Portlet MVC. This is my first attempt at deploying a Spring MVC portlet to uPortal 2.5.3 and am experiencing an error. The error I am getting is as follows. Any help is appreciated. I have deployed to the portal before without issue.

    Code:
    org.jasig.portal.PortalException: Initialization of the portlet container failed.
    	at org.jasig.portal.channels.portlet.CPortletAdapter.initPortletWindow(CPortletAdapter.java:270)
    	at org.jasig.portal.channels.portlet.CPortletAdapter.setRuntimeData(CPortletAdapter.java:414)
    	at org.jasig.portal.MultithreadedCharacterChannelAdapter.setRuntimeData(MultithreadedCharacterChannelAdapter.java:29)
    	at org.jasig.portal.ChannelRenderer$Worker.execute(ChannelRenderer.java:460)
    	at org.jasig.portal.utils.threading.BaseTask.run(BaseTask.java:27)
    	at edu.emory.mathcs.backport.java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:431)
    	at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.run(FutureTask.java:166)
    	at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:643)
    	at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:668)
    	at java.lang.Thread.run(Thread.java:595)
    Caused by: javax.portlet.PortletException: Unable to find dispatcher for context: null
    	at org.apache.pluto.invoker.impl.PortletInvokerImpl.invoke(PortletInvokerImpl.java:166)
    	at org.apache.pluto.invoker.impl.PortletInvokerImpl.load(PortletInvokerImpl.java:80)
    	at org.apache.pluto.PortletContainerImpl.portletLoad(PortletContainerImpl.java:203)
    	at org.jasig.portal.channels.portlet.CPortletAdapter.initPortletWindow(CPortletAdapter.java:262)
    Last edited by Howler72; Sep 4th, 2008, 05:06 PM.

  • #2
    Sounds like a uPortal problem -- not a Spring MVC problem. I suggest you post your question on the uPortal User mailing list:

    http://www.ja-sig.org/wiki/display/JSG/uportal-user

    Comment

    Working...
    X