Announcement Announcement Module
Collapse
No announcement yet.
Deploying petportal in BEA weblogic Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Deploying petportal in BEA weblogic

    Hi, guys,
    I am trying to understand how to develop a portal application using spring MVC portlet framework, I downloaded the Spring framework, it has a "petPortal" example included in it, and it's the requirement of my client to develop my application with BEA weblogic. But I have a problem doing this.
    I run the build.bat and warfile.bat file, it works, and I imported the petportal.war file to the BEA workshop studio, which is basically an IDE similar to the Eclipse. It reports errors, so I added portlet.jar and any jar I can imagine in the application build path. It compiles finally, but when I try to run the whole project, I got an 404 error.
    And it's kinda strange that after importing the war file, I didn't get the index.jsp.......
    Does anybody know how to deploy this petPortal example to weblogic server? This has beening torturing me for couple days. Thank you in advanced.
    Logan

  • #2
    It's important to understand the portlet applications do not deploy into just a servlet container. The must be deployed into a portlet container and there must be a portal layer to provide the main user interface. Take a look at this FAQ entry for more information.

    Comment


    • #3
      Originally posted by johnalewis View Post
      It's important to understand the portlet applications do not deploy into just a servlet container. The must be deployed into a portlet container and there must be a portal layer to provide the main user interface. Take a look at FAQ entry for more information.

      Thank you very much for your reply, I did try some of the tools provided by BEA itself, like:
      http: //dev2dev.bea.com /pub/a/2004/09/deployJava81sp3.html (i can't post URL, please remove the space in the URL)
      I used it with WebLogic 8.1 sp3 (exactly as what the article says)

      after fixing a series of errors, I came to one of those that I can't overcome,

      D:\temp>ant Dwar.file=petportal
      Buildfile: build.xml

      BUILD FAILED
      D:\temp\build.xml:2: taskdef class com.bea.task.PreparePortlets cannot be found

      Total time: 0 seconds


      I set the classpath as the env.bat instructed, instead of running it directly(because running it disables Ant)

      I am running out of time, and doesn't seem to find a clue, torturing......

      Comment


      • #4
        Well, your issue is clearly a BEA problem of some kind seeing as Ant cant kind a class that it needs for its task definition. I suggest you review your Ant configuration and see if you can get some help from BEA support or in their discussion forums.

        Comment


        • #5
          yeah, I know it's not a spring problem, I am posting this just to see whether others are encountering the same issue. Thank you anyway.

          Comment

          Working...
          X