Announcement Announcement Module
Collapse
No announcement yet.
Tiles 2 Maven dependencies Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Tiles 2 Maven dependencies

    Hi all,

    I'm having a basic issue configuring Spring 2.5 to use Tiles2. I'm using Eclipse with the Maven2 plug-in.

    I have a configurer wired up in my Spring configuration:
    HTML Code:
    <bean id="tilesConfigurer" class="org.springframework.web.servlet.view.tiles2.TilesConfigurer">
      	<property name="definitions">
      	  <list>
      	    <value>/WEB-INF/tiles/defs-main.xml</value>
      	  </list>
      	</property>
      </bean>
    In my pom.xml file, I have the following dependencies:
    HTML Code:
      <dependency>
        <groupId>org.apache.tiles</groupId>
        <artifactId>tiles-core</artifactId>
        <version>2.0.5</version>
      </dependency>
      <dependency>
        <groupId>org.apache.tiles</groupId>
        <artifactId>tiles-jsp</artifactId>
        <version>2.0.5</version>
      </dependency>
    I can see in my "Maven Dependencies" project nature in Eclipse that Tiles api, core and jsp jars are all available, but when I try to deploy, I get a

    Code:
    java.lang.NoClassDefFoundError: org/apache/tiles/factory/TilesContainerFactory
    I can't seem to find the solution to my issue answered elsewhere. Any help at all would be appreciated.

    Thanks in advance.
    nate

  • #2
    This seemed to be a bad state problem with Eclipse. Restarting the application solved the problem.

    Comment

    Working...
    X